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Worked Examples 1 

1 INTRODUCTION 
 

1.1 How To Use This Guide  
This volume is designed to introduce you to progressively more advanced features of CRISP2D by way of 
a series of worked examples.  Each example comprises a brief description of each of these stages followed 
by step-by-step instructions as to how to complete every stage. 

Each worked example introduces either new features or different ways of using existing features.  By the 
end of the last worked example you will have a good idea as to the use of every feature in CRISP2D. 

It is assumed that you have a good knowledge of soil mechanics, that you have used Windows before and 
that you know the standard terminology used to describe Windows artefacts. 

Please Note: only examples 1 - 3 can be carried out using the evaluation version of CRISP2D and that 
some of the features shown in the manual have been disabled. 

1.1.1 Examples 
The examples are intended to provide a source of guidance for the use of CRISP2D interface.  It is 
important to note that the examples are limited in size to allow the completion of the example in an 
acceptable time.  For more complex problems you should refer to the publications directory supplied with 
CRISP2D.  Five examples are included that cover simple lab tests to major engineering activities. 

 Triaxial Test 

 Oedometer Test 

 Analysis of a strip footing 

 Construction of an embankment, and 

 Construction of a retaining wall 

1.2 Using The Manuals 
Volume I contains detailed descriptions on how to use every feature in the interface to help you create 
meshes, apply analysis conditions, run the analysis and post process the output.  It also contains a chapter 
that introduces you to Windows and the terminology you need to know to make the most efficient use of 
these manuals. 

Volume II contains a wealth of information detailing how you should go about setting up a finite element 
analysis (FEA) including selecting the correct type of finite element, choosing a soil model, deriving 
material parameters and setting in situ conditions to name but a few sections. 

The Publications Directory is provided as a source of reference information so that you can see the 
different ways in which CRISP has been used to model particular problems in the past. 
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2 ONE 
DIMENSIONAL 
CONSOLIDATION 
TEST 

 

2.1 Introduction 
The subject of this example is a one-dimensional Terzaghi consolidation. 

The estimated time is 30 - 45 minutes. 

The following steps will be covered: 

 Starting The Project 

 Defining Units 

 Creating The Finite Element Mesh 

 Defining A Material Zone 

 Assigning Element Properties 

 Defining In Situ Stress Conditions 

 Defining Increment Blocks 

 Defining Boundary Conditions 

 Defining Loads 

 Scale Factors 

 Running The Analysis 

 Displacement Plots 

 Duration Graphs 

Worked Examples 2 
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2.2 The Problem 
The consolidation problem under consideration is illustrated in Figure  2-1.  The finite element mesh that 
will be used consists of 2 linear strain triangle (LST) elements. 

 
Figure  2-1:One Dimensional Terzaghi Consolidation 

The one-dimensional consolidation of an axisymmetric sample is chosen to illustrate the use of 
consolidation elements.  Two linear strain triangles are used in the mesh. 

Figure  2-1 shows the mesh and the boundary conditions.  The vertical sides and bottom of the sample are 
restrained and they are assumed to be smooth.  The sample is initially unstressed, i.e. in situ stresses are 
set to zero.  The sample has a radius of 1000 mm and is 1000 mm in height.  The top surface is loaded 
with 100 kPa instantaneously.  For computational purposes this load is applied over a small time period of 
0.1 sec.  The transient response during 20 secs after the load application is studied in the analysis.  In the 
first increment, the drainage conditions are applied.  The load is applied in the second increment.  The 
third increment block consists of increments 3 to 9, whose time steps are 1, 1, 1, 1, 1, 5 and 10 secs 
respectively. 

It  is recommended in consolidation analyses involving applied loads that the pore water pressure 
boundary conditions be specified in a separate increment block to the loads.  In this example, the total 
pore water pressure is set to zero along the top of the sample in the first increment block and the load is 
applied in the second increment block. 

2.3 Pre-Processing 
This section describes all of the stages that must be completed using the Pre-Processor in order to run the 
finite element analysis.  It is recommended that you save the Project regularly (by selecting Save 
Project from the File menu). 

Worked Examples 3 
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2.3.1 Starting The Project 
This section describes the basic processes that should be completed in advance of creating your mesh.  
This involves entering data to set-up various run-time options for the finite element analysis and to 
descriptively identify the Project.  The base units are also verified. 

The following procedure describes the initial setup of the Project. 

On opening the CRISP2D Pre-Processor, select New Project... from the File menu.  This displays the 
Mesh Mode dialogue box. 

Click on the Finite Mesh button.  This exits the Mesh Mode dialogue box, sets you up in Finite Element 
mode and opens the Project Setup dialogue box. 

 
Figure  2-2:Project Setup dialogue box 

Click on the Axisymmetric option button and on All Other Elements to select the analysis type and 
permissible element types, respectively. 

The Project Setup should now look like Figure  2-2. 

Click on the Info... button.  This displays the Project Information dialogue box. 

Worked Examples 4 
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Figure  2-3:Project Information dialogue box 

Enter data as appropriate.  The date is automatically entered but may be manually altered. 

The Project Information dialogue box should now look similar to Figure  2-3.  Click on OK to return to the 
Project Setup dialogue box once you have finished. 

Click on OK to exit. 

2.3.2 Defining Units 
At this point it is useful to ensure that the correct system of base units is being used.  For this example, 
kilonewtons, millimetres, seconds and degrees form the base units. 

           Step 1 In the Options menu, click on Units... to display the Units dialogue box. 

 
Figure  2-4:Defining Base Units 

           Step 2 Use the list boxes to select the appropriate units for Distance, Force, Time and 
Angle as shown in Figure  2-4.  Click on OK to exit once you have finished. 

2.3.3 Creating The Finite Element Mesh 

Worked Examples 5 
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The Project is now ready for you to define your finite element mesh.  The quickest, most accurate way to 
create a small, regular mesh is to use the Node List to define the vertices and then join them together to 
form the finite elements. 

           Step 1 In the Mesh menu, click on Node List... to display the Node List dialogue box. 

           Step 2 Click on the empty x co-ordinate cell and type ‘0’.  Press the TAB key to move to 
the y co-ordinate cell and enter ‘0’ here. 

           Step 3 Press the TAB key again.  This moves you into the x co-ordinate cell for the next 
node.   Enter an x value of ‘1000’ and a y value of ‘0’. 

           Step 4 Using the TAB key to move between cells, enter a total of four nodes with co-
ordinates (0 , 0), (1000 , 0), (1000 , 1000) and (0 , 1000), as shown in Figure  2-5. 

 
Figure  2-5:Node List dialogue box 

           Step 5 Click on OK to exit once you have finished. 

           Step 6 The Graphics Window will now display the nodes you have created.  To view 
them at optimum scale select Full Page from the Zoom list box on the main 
toolbar. 

           Step 7 In the View menu, click on Node Numbers to switch on the display of node 
numbers. 

           Step 8 In the Mesh menu, click on Create Element.  Using the left-hand mouse 
button click on (or close to) node 1, node 2, node 3 and then node 1 again.  Lines 
will appear joining these nodes and creating an element.  Repeat the process, this 
time clicking in turn on nodes 3, 4, 1 and then 3 again. 

           Step 9 When you click again on the first node, the element’s edges change colour to 
indicate that the element is now closed (i.e. complete).  When you start creating 
the second element, the first element’s edges will again change colour- this time 
to indicate that you have begun working on a new, separate element. 
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12BPre-Processing 
 

Tip Note that if you try to start creating the second element by clicking again 
on node 1, you will actually un-create the first element. 

 This is because each time you click on a node you toggle its selected 
status.  This means that by trying to start the second element from the lead 
node of the first element you are deselecting that node and making it no 
longer form a vertex for the first element. 

           Step 10 Once the second element is created the Graphics Window will look something 
like Figure  2-6.  In the Edit menu, click on Commit Element Creation. 

 
Figure  2-6:The Finite Element Mesh 

2.3.4 Defining A Material Zone 
A Material Zone contains information about the soil model and associated soil parameters that are being 
used to model  particular regions of the mesh. 

It is necessary to define the number of material zone(s) at this point in order to be able to allocate them 
using the Element Properties dialogue box.  As they are referenced by name, a meaningful title is also 
given. 

Having set up a zone, the soil model and parameters may be entered or changed at any time prior to the 
analysis being run. 

           Step 1 In the Mesh menu, click on Material Properties... to display the Material 
Properties dialogue box. 
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Figure  2-7:Material Properties for Oedometer Test 

           Step 2 Enter the name “Remoulded clay” from the Soil Models list box.  Elastic is 
already shown, being the default. 

           Step 3 Enter the following soil parameters: 

 

Property Value Units 

Eh 0.01 kN/mm2 

Ev 0.01 kN/mm2 

vhh 0.1 - 

vvh 0.1 - 

Ghv 4.545 E-2 kN/mm2 

Kw / γw 1.0 E-8 kN/mm3 

γbulk 0 kN/mm3 

kx 0.1 mm/s 

ky 0.1 mm/s 

 

           Step 4 The Material Properties dialogue box should now look similar to Figure  2-3.  
Click on OK to exit once you have finished. 

Tip In this example the soil properties are entered at this stage.  If you prefer, 
you can enter and change the values at any time prior to running the 
analysis. 

2.3.5 Assigning Element Properties 
Every element in the mesh has two properties associated with it:  

 Finite element type, and 
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 Material zone 

These properties are assigned to finite elements in the following manner: 

           Step 1 In the Select menu, click on Domain Elements and select both elements by 
clicking on them.  Selected elements are indicated by a user defined colour fill. 

           Step 2 You can deselect elements by clicking on them again. 

           Step 3 In the Mesh menu, click on Element Properties... to display the Element 
Properties dialogue box.  Because the elements both have three sides, the 
quadrilateral element options are unavailable. 

 
Figure  2-8:Defining Element Type and Zone 

           Step 4 Click on Linear Strain Triangle (consolidating). 

           Step 5 Select ‘Remoulded clay’ from the Material Zone list box. 

           Step 6 The Element Properties dialogue box should now look like Figure  2-8.  Click on 
OK to exit once you have finished. 

2.3.6 Defining In Situ Stress Conditions 
This allows you to define the initial state of stress experienced by the mesh.  However, in this example all 
in situ stresses are zero. 

           Step 1 In the Increment menu, click on Define In Situ Stress Conditions... to 
display the In Situ Stress Setup dialogue box. 
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Figure  2-9:Zero In Situ Stresses 

           Step 2 Click on OK to exit.  This records a zero in situ stress state. 

2.3.7 Defining Increment Blocks 
Increments are the units by which the finite element program advances the analysis.  In each increment, 
the effect of applied loads and boundary conditions are calculated and the accumulated strains and pore 
water pressures are updated.  Increments are grouped together in blocks which then model particular 
events in the analysis. 

This analysis requires three increment blocks.  The first models the pore water pressure boundary 
conditions.  The second models the instantaneously applied load.  The third simulates the dissipation of 
excess pore pressures and the resulting consolidation using seven increments. 

           Step 1 In the Increment menu, click on Define Increment Block Parameters... to 
display the Increment Block dialogue box. 
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Figure  2-10:Increment Block dialogue box 

           Step 2 A default block called ‘Increment Block (untitled)’ is automatically created 
because no other blocks exist.  Change the name  to “Apply pwp fixity” in the 
Description of Block text box. 

           Step 3 Allocate a single increment and a time-step for the block of 0.1 seconds. 

           Step 4 Click on New to create another increment block and call it “Loading stage”. 

           Step 5 Allocate a single increment and a time-step for the block of 0.1 seconds. 

           Step 6 Click on New to create another increment block and call it “Consolidation 
stage”. 

           Step 7 Assign seven increments and a time-step for the block of 20 seconds to this 
block. 

           Step 8 Click on the Define... button.  This displays the Define Load/Time Steps 
dialogue box. 

 
Figure  2-11:Defining Load and Time Steps 
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           Step 9 In the Time Step column enter 1 second into the first five increments, 5 into the 
sixth and 10 into the seventh.  This is the exact distribution of the 20 second total 
time-step. 

           Step 10 The Define Load/Time Steps dialogue box should now look like Figure  2-11.  
Click on OK to return to the Increment Block dialogue box, once you have 
finished. 

           Step 11 Upon clicking OK, a prompt will appear because the time-steps do not equal 
100%, asking if you require automatic smoothing.  Select Yes and the values 
will be multiplied by a common factor so that they total 100. 

           Step 12 Click on OK to exit the Increment Block dialogue box 

 

2.3.8 Defining Boundary Conditions 
Boundary conditions describe to the finite element analysis the ways in which the mesh is physically 
restrained from moving and the drainage features whose effects must be accounted for.  This is achieved 
by applying fixities to edges and nodes in the mesh. 

Once defined, fixities apply in all successive increment blocks.  The Fixities dialogue box and the 
Graphics Window (if View Fixities is toggled on) will only display any fixity that is applied during the 
current increment block. 

This example incorporates a pore water pressure fixity along the top edge.  It is recommended that pore 
pressure fixities not be applied in the same increment block as any loads are applied.  According to this, 
displacement fixities will be applied at the in situ stage, pore pressure fixities in the first increment block 
and the load in the second block. 

See Section 6.5 in the Technical Reference Guide for further details about applying pore pressure fixities 

The following procedure defines the fixities: 

           Step 1 Ensure that ‘In situ’ is selected from the Increment Block list box on the main 
toolbar. 

           Step 2 In the Select menu, click on Edges. 

           Step 3 Select the left-hand and right-hand (vertical) edges of the mesh by clicking on 
them.  Both of these edges will have zero X direction fixity, so they can be 
defined simultaneously. 

           Step 4 In the Increment menu, click on Fixities... to display the Edge Fixity dialogue 
box. 
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Figure  2-12:Zero X Direction Fixities 

           Step 5 Click on the X displacement option and type ‘0’ into the Start Node and 
Finish Node text boxes.  Now set the Mid Value fixity to zero by either 
pressing the Interpolate button or by typing in ‘0’ directly. 

           Step 6 The Edge Fixity dialogue box should now look like Figure  2-12.  Click on OK 
to exit once you have finished. 

           Step 7 Click on Clear Selection in the Select menu to ensure that no edges are 
selected (Select Edge remains active).  Then select the bottom (horizontal) edge 
of the mesh by clicking on it. 

           Step 8 In the Increment menu, click on Fixities.... 

           Step 9 Click on the Y displacement option and define zero fixities, as above. 

           Step 10 Click on OK to exit once you have finished and click on the bottom edge of the 
mesh to de-select it. 

           Step 11 The Graphics Window should now look similar to Figure  2-13.  Note that the 
display of fixity icons can be turned on and off by clicking on Fixities in the 
View menu and that their size can be controlled in the Default Settings dialogue 
box (accessed via the Options menu). 
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Figure  2-13:Displacement Fixities (at the In Situ  Stage) 

           Step 12 Select ‘Apply pwp fixity’ from the Increment Block list box on the main tool 
bar. 

           Step 13 Click on Clear Selection in the Select menu to ensure that no edges are 
selected and select the top (horizontal) edge of the mesh by clicking on it. 

           Step 14 In the Increment menu, click on Fixities.... 

           Step 15 Click on the Pore Water Pressure option.  This will activate the pore 
pressure fixity group of options. 

 
Figure  2-14:Applying A Pore Pressure Fixity 

           Step 16 Click on the Total option and enter zeroes into the Start Node, Finish Node 
and Mid Value text boxes. 
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           Step 17 Click on OK to exit.  This concludes the application of boundary conditions. 

2.3.9 Defining Loads 
A load is applied to the top edge of the mesh during the second increment block, but with a very small 
time increment so that the effect is one of instantaneous application. 

As with fixities, once defined loads apply in all successive increment blocks.  The Loads dialogue box and 
the Graphics Window (if View Loads is toggled on) will only display any load that is applied during the 
current increment block. 

           Step 1 Select ‘Loading stage’ from the Increment Block list box on the main toolbar. 

           Step 2 Click on Clear Selection in the Select menu to ensure no edges are selected. 

           Step 3 Select the top (horizontal) edge of the mesh by clicking on it. 

           Step 4 In the Increment menu, click on Loads... to display the Edge Load dialogue 
box. 

           Step 5 The applied loading is to be 100 kN/m2, so enter a value of 0.0001 kN/mm2 into 
the Normal Start node and Normal Finish node text boxes.  Click on 
Interpolate and the Normal Mid Value will automatically be entered as  
0.0001 kN/mm2.  Alternatively the value can be entered manually. 

           Step 6 The Edge Load dialogue box should look like Figure  2-15.  Click on OK to exit 
once you have finished. 

 
Figure  2-15:Loading the Top Edge 

2.3.10 Scale Factors 
Loads are displayed on the Graphics Window as arrows whose length is proportional to the size of the 
load.  In order to optimise the display of these arrows, a scaling factor can be specified that will increase 
or decrease the length of every load arrow in the mesh by the same proportion. 

Customising the display of loads in this way takes three forms- Shear load scale, Normal load scale and 
Offset (the distance between the arrow head and the edge or node to which it applies). 

This dialogue box also controls the display of text (node numbers, element numbers, etc.) and icons (such 
as those used to represent fixities).  The displayed size of these can be controlled by changing the scale 
factor values in the Text and Icons section. 
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           Step 1 In the Options menu, click on Default Settings... to display the Defaults 
dialogue box. 

 
Figure  2-16:Setting Scale Factors 

           Step 2 Click on the Scale Factors tab. 

           Step 3 Enter values of 0.002 in the Normal text box and 0.1 in the Offset text box. 

           Step 4 If your fixity icons do not look anything like those shown in Figure  2-13, try 
changing the size by altering the basic display size.  Values of 10 and 1 (as 
shown in Figure  2-17) were used to produce Figure  2-13. 

           Step 5 The Defaults dialogue box should look like Figure  2-17.  Click on OK to exit 
once you have finished.  The Graphics Window should look similar to 
Figure  2-17. 

 
Figure  2-17:Loading Applied to the Top of the Sample 
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2.3.11 Running The Analysis 
The Project should now be saved.  This concludes the pre processing for this particular problem so all that 
remains is for you to run the finite element analysis program. 

           Step 1 In the File menu, click on Run Analysis... to run the finite element analysis.  
This displays the Run Analysis dialogue box. 

 
Figure  2-18:The Run Analysis dialogue box 

           Step 2 Click on Create CRISP Files Now.  This will write two files with the 
extension .GPR and .MPD to disk.  These files contain the input data required by 
the finite element analysis program.  If any errors in the analysis data are 
encountered, you will be informed of the problem by a message. 

           Step 3 Provided no errors were encountered, click on Run Analysis Now.  This will 
envoke the CRISP analysis engine modules (geometry program and main 
program). 

           Step 4 When the analysis is finished, you will be returned to Windows and the output 
from the analysis is converted into a Microsoft Access 2.0 database.  A 
percentage bar informs you as to how long you have left to wait. 

           Step 5 You can load your results directly into the Post-Processor by clicking on the 
Post-Processor button in the Analysis Docker dialogue box. 

2.4 Post-Processing 
The Post-Processor contains a set of features that allow you to look at the output from your analysis. 

In this section you will be introduced to the following features: 

 Displacement Plots 

 Duration Graphs (using nodes and integration points) 

2.4.1 Introduction 
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If you entered the Post-Processor directly from running the analysis, your Project will already be loaded.  
However you may also enter the Post-Processor by double-clicking on its icon in the CRISP2D program 
group in Windows’ Program Manager.  In this case, you should select Open Project... from the File menu 
and, provided the analysis has been successfully run, you will be able to post process the output from your 
analysis. 

The example assumes that you have successfully loaded the one dimensional consolidation Project into 
the Post-Processor. 

2.4.2 Displacement Plots 
Displacement plots are drawn directly onto the Graphics Windows.  They provide a representation of how 
the mesh has deformed at any stage in the analysis.  You can view either vector displacements or the 
deformed mesh at any specified magnification. 

           Step 1 In the Plots menu, click on Displacement Plots... to display the 
Displacement Plot dialogue box. 

 
Figure  2-19:Displacement Plot dialogue box 

           Step 2 Click on the New button to create your plot and change the title to ‘Final 
deformed mesh’. 

           Step 3 Select the Deformed Mesh option. 

           Step 4 Ensure that Absolute is selected and that the Start increment is 9. 

           Step 5 Enter a Magnification Factor of 10.  The Displacement Plot dialogue box should 
look similar to Figure  2-19. 

           Step 6 Click on OK to exit once you have finished.  The plot will be displayed on the 
Graphics Window similar to Figure  2-20. 
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Figure  2-20:Deformed Mesh After Full Consolidation 

Tip Displacement plots look clearer if you select good line styles and colours.  
To change the line styles, select Line Styles... from the Options menu.  To 
change the line colours, select Line Colours... from the options menu. 

2.4.3 Duration Graphs 
Duration graphs allow you to investigate the variation of output from individual integration points or 
nodes over the course of a specified range of increments. 

Up to 10 data sets (each one representing a different integration point or node) can be viewed on the same 
graph, but for this example a single node will be used. 

Two Duration graphs will be produced here: 

 Vertical Displacement plotted against Time, for the top left node 

 Total Pore Pressure plotted against Time, for two integration points 

Vertical Displacement vs Time 
Displacement in this example is purely in the vertical direction (as confirmed by the Displacement Plot 
produced earlier).  Therefore, the amount of vertical displacement experienced by the top edge can be 
plotted on a graph drawn from either one of the nodes along the top edge. 

The following procedure describes how to create a graph plotting the movements of  the top, left-hand 
node: 

           Step 1 In the Select menu, click on Nodes and then on Clear Selection.  Select the 
node at the top left corner of the mesh by clicking on or close to it. 
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           Step 2 In the Plots menu, click on Duration Graphs... to display the Duration Graphs 
dialogue box. 

 
Figure  2-21:Duration Graph dialogue box 

           Step 3 Click on the New button to create your graph and change the title to “Deflection 
of loaded edge”. 

           Step 4 Ensure that the Increment Range starts at 1 and finishes at 9. 

           Step 5 Select ‘Time’ as X Axis data and ‘Vertical displacement’ as Y Axis data.  The 
Duration Graph dialogue box should now look similar to Figure  2-21. 

           Step 6 Click on OK to exit once you have finished.  The graph will be displayed with a 
configuration that depends upon your default settings.  It should look similar to 
Figure  2-22. 

           Step 7 If the graph does not look very similar, you can change the settings (axis labels, 
titles and legend) in the Graph Configuration dialogue box.  This can either be 
accessed from the Options menu, or by double clicking on the graph itself.  This 
graph has no legend, no grid lines, 11 X axis divisions, 10 Y axis divisions, X 
axis minima and maxima of 0 and 22, Y axis minima and maxima of -0.01 and 0. 

Worked Examples 20 



13BPost-Processing 
 

 
Figure  2-22:Graph Showing Vertical Deflection of the Sample 

Total Pore Pressure vs Time 
The following procedure describes how to create a plot showing the dissipation of pore pressure with time 
for two points in the mesh.  These points are the centroids of the two elements and are respectively 1/3 in 
and 2/3 up, and 2/3 in and 1/3 up from the bottom left-hand corner. 

The graph is plotted according to the following procedure: 

           Step 1 To reactivate the Graphics Window, click on Cascade or on Tile 
Horizontally in the Window menu.  These options allow you to switch between 
the Graphics Window and any graphs that are on display. 

           Step 2 In the Select menu, click on Integration Points.  This will automatically 
action Integration Points in the View menu so that they appear on screen. 

           Step 3 Select the integration point at the centre of each element. 

           Step 4 In the Plots menu, click on Duration Graphs... to display the Duration Graphs 
dialogue box. 

           Step 5 Click on the New button to create your graph and change the title to 
“Dissipation of Pore Pressure”. 

           Step 6 Ensure that the Increment Range starts at 1 and finishes at 9. 

           Step 7 Select ‘Time’ as X Axis data and ‘Total Pore Pressure’ as Y Axis data. 

           Step 8 Click on OK to exit once you have finished.  The graph displayed should look 
similar to Figure  2-23. 
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           Step 9 This graph is configured with a legend, no grid lines, 11 X axis divisions, 6 Y 
axis divisions, X axis minima and maxima of 0 and 22, Y axis minima and 
maxima of 0 and 120. 

 
Figure  2-23:Graph Showing the Dissipation of Total Pore Pressure 

Note that the γbulk value of the soil was set to zero in this analysis so that the in situ stresses could be set to 
zero.  This allows the dissipation of pore pressure to be illustrated much clearer.  It is only very rarely that 
the in situ stresses are set to zero. 

2.5 Summary 
By the end of this example you will have made use of the following features: 

 Units 

 The Node List 

 Creating finite elements 

 Material zones 

 In situ stresses 

 Increment blocks 

 Displacement and pore water pressure fixities 

 Loads 

 Load scale factors 

 Displacement plots 
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 Duration graphs 

2.6 Things To Try Next 
 Try using more increments (with smaller time-steps) to more accurately capture 

the sample’s behaviour at the beginning of consolidation. 

 Try creating a mesh with 8 elements to see how mesh geometry affects the 
results. 

 Try using cubic strain triangles to see how the use of a higher order element 
influences the results. 

 Try using non consolidation elements and drained material values to see if the 
drained condition is the same as the long term consolidation condition. 
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3 UNDRAINED 
TRIAXIAL TEST  

3.1 Introduction 
This example is designed to introduce you to one of the family of critical state soil models, namely the 
Cam clay model.  The example does not aspire to impart you with a knowledge of critical state soil 
mechanics, so it is recommended that it only be attempted if you are already familiar with critical state 
theory.  The subject of the example is a strain controlled, undrained triaxial test. 

The following steps will be covered: 

 Starting The Project 

 Defining Units 

 Creating The Finite Element Mesh 

 Defining A Material Zone 

 Assigning Element Properties 

 Defining In Situ Stress Conditions 

 Defining Increment Blocks 

 Defining Boundary Conditions 

 Defining Loads 

 Scale Factors 

 Running The Analysis 

3.2 The Problem 
The triaxial problem under consideration is illustrated in Figure 2-1.  Because of consideration of 
symmetry only a quarter section needs to be considered for this analysis.  The finite element mesh that 
will be used consists of 2 linear strain triangle elements.  Cubic strain triangles are recommended for 
axisymmetric problems, but for this simple example their use is not required. 

See the Technical Reference Guide for further information about choosing the right type of finite element 
for your problem. 
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Figure  3-1:Triaxial Test Cell 

The soil sample is isotropically consolidated to 200 kPa and then isotropically unloaded to a mean normal 
stress of 150 kPa.  A standard undrained compression test is then carried out.  The Cam clay parameters 
selected for the soil are as follows: 

 λ  =  0.30 κ  =  0.05 M  =  1.0 

 ecs  =  2.953 ν′  =  0.3 

As this is an undrained analysis, the bulk modulus of water is required to complete the data on material 
properties. 
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For undrained analyses the bulk modulus of water approximately 100 K′ (7.655 x 105  kPa).  In the 
analysis presented here a value of 5.0 x 105 kPa was used. 
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More than 50 load increments are recommended for an finite element analysis which simulates a triaxial 
test.  For the purposes of this example however, only six load increments will be used. 

A strain controlled test is considered here with 0.5% axial strain in each increment, leading to a total axial 
strain of 3%.  The left-hand edge is restricted to move vertically and the top and bottom edges are 
restricted to move horizontally.  The top edge is displaced vertically downwards to simulate a strain 
controlled test. 

The results of the analysis are plotted in q - εa, u - εa, and q - p′ space 

.  These are compared with the theoretical and also with an analysis using a large number of increments.  
These differences between theory and predictions are due to the large increment size which was used 
solely for illustrative purposes.  During the second increment the yield ratio (YR) is on average about 
1.12, i.e. the yield locus has grown in size by 12%.  Stricter control on YR is recommended so that the 
change in size of the yield locus is not more than 3%  (i.e. YR 1.03 when hardening or 0.97 when 
softening).  The results emphasise the importance in selecting the size of load increment:  as shown here 
large load increments may lead to erroneous results. 

3.3 Pre Processing 
This section describes all of the stages that must be completed using the Pre-Processor in order that the 
analysis can be run.  It is recommended that you save the Project regularly. 

3.3.1 Starting The Project 
This section describes the basic processes that should be completed in advance of creating your mesh.  
This involves entering data to set-up various run-time options for the finite element analysis and to 
descriptively identify the Project.  The base units are also verified. 

The following procedure describes the initial set-up of the Project. 

           Step 1 On opening the CRISP2D Pre-Processor, click on New Project... in the File 
menu.  This displays the Mesh Mode dialogue box. 

           Step 2 Click on the Finite Mesh button.  This exits the Mesh dialogue box, sets you 
up in Finite Element mode and opens the Project Setup dialogue box. 

           Step 3 In the Domain Type section, click on the Axisymmetry option button and click 
on All Other Elements in the Element Type section. 

           Step 4 Enter an in situ gravity level of 1 G. 

           Step 5 The dialogue box should now look like Figure  3-2.  Click on OK to exit once 
you have finished. 
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Figure  3-2:Project Setup dialogue box 

           Step 6 Click on the Info... button.  This displays the Project Information dialogue box. 

 
Figure  3-3:Project Information dialogue box 

           Step 7 Enter data as appropriate.  The date is automatically entered but may be 
manually altered. 

           Step 8 The Project Information dialogue box should look similar to Figure  3-3.  Click 
on OK to return to the Project Setup dialogue box once you have finished. 

           Step 9 Click on OK to exit. 

3.3.2 Defining Units 
At this point it is useful to ensure that the correct system of base units is being used. 

           Step 1 In the Options menu, click on Units... to display the Units dialogue box. 
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Figure  3-4:Defining Base Units 

           Step 2 Use the list boxes to select the appropriate units for Distance, Force, Time and 
Angle as shown in Figure  3-4. 

           Step 3 Click on OK to exit once you have finished. 

3.3.3 Creating The Finite Element Mesh 
The Project is now ready for you to define your finite element mesh.  The quickest, most accurate way to 
create a regular mesh is to first use the Node List to define the vertices, which can then be easily linked to 
form the mesh elements. 

           Step 1 In the Mesh menu, click on Node List... and enter four nodes with co-ordinates 
( 0 , 0 ), ( 1 , 0), ( 1 , 1 ) and ( 0 , 1 ) into the Node List dialogue box, as shown in 
Figure  3-5. 

 
Figure  3-5:Node List dialogue box 

           Step 2 Click on OK to exit once you have finished. 

           Step 3 The Graphics Window now displays the nodes you have created.  To view them 
at optimum scale, select ‘Full Page’ from the Zoom list box on the main 
toolbar. 
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           Step 4 In the View menu, click on Node Numbers to switch on the display of node 
numbers. 

           Step 5 In the Mesh menu, click on Create Domain Element.  Using the left-hand 
mouse button click on (or close to) node 1, node 2, node 3 and then node 1 
again.  Lines will appear joining these nodes and creating an element.  Repeat 
the process clicking in turn on nodes 3, 4, 1 and then 3 again.  As you start 
creating the second element, the first will change colour (the colours are 
definable in the Colours dialogue box, which is accessed via the options menu). 

Tip Note that if you try to start creating the second element by clicking again 
on node 1, you will actually un-create the first element. 

 This is because each time you click on a node you toggle its selected 
status.  This means that by trying to start the second element from the lead 
node of the first element you are deselecting that node and making it no 
longer form a vertex for the first element. 

           Step 6 Once the second element is created, in the Edit menu, click on Commit 
Elements.  This fixes the newly created elements, confirming that they are 
correctly created, the Graphics Window will look something like Figure  3-6. 

 
Figure  3-6:The Finite Element Mesh 

3.3.4 Defining A Material Zone 
A Material Zone contains information about the soil model and associated soil parameters that are being 
used to model  particular regions of the mesh. 

It is necessary to define the number of material zone(s) at this point in order to be able to allocate them 
using the Element Properties dialogue box.  As they are referenced by name, a meaningful title is also 
given. 
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Having set up a zone, the soil model and parameters may be entered or changed at any time prior to the 
analysis being run. 

           Step 1 In the Mesh menu, click on Material Properties... to display the Material 
Properties dialogue box. 

 
Figure  3-7:Material Properties for Undrained Triaxial Test 

           Step 2 Enter the name “Overconsolidated Kaolin Clay” and select ‘Cam clay’ from the 
Soil Models list box. 

           Step 3 Enter the following soil parameter values: 

 

Property Value Units 

κ 0.05 None 

λ 0.3 None 

ecs 2.953 None 

M 1.0 None 

G or ν ′ 0.3 None 

Kw / γw 5.0E05 kN/m3 

γbulk 20 kN/m3 

kx 0 m/s 

ky 0 m/s 

 

           Step 4 The Material Properties dialogue box should now look like Figure  3-7.  Click on 
OK to exit once you have finished.  Note that kx  and ky are not required for an 
undrained analysis. 

Tip It is not necessary to define permeability values for analyses which do not 
have consolidation elements. 
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3.3.5 Assigning Element Properties 
Every element in the mesh has two properties associated with it:  

 Finite element type, and 

 Material zone 

These properties are assigned to finite elements in the following manner: 

           Step 1 In the Select menu, click on Domain Element and select both elements by 
clicking on them. 

           Step 2 In the mesh menu, click on Element Properties... to display the Element 
Properties dialogue box.  Because the elements have the same number of sides, 
their properties can be defined simultaneously. 

 
Figure  3-8:Defining Element Type and Zone 

           Step 3 As the selected elements have 3 sides, their Element Type is automatically fixed 
as Linear Strain Triangle.  Select the (non consolidating) option. 

           Step 4 Select ‘Overconsolidated Kaolin Clay’ from the Material Types list box.  If you 
have been following the example this will be the only option in the list. 

           Step 5 The Element Properties dialogue box should now look like Figure  3-8.  Click on 
OK to exit once you have finished. 

3.3.6 Defining In Situ Stress Conditions 
This allows you to define the initial state of stress experienced by the mesh.  Although the Stress 
Conversion Parameters dialogue box provides a means of automatically calculating in situ stresses, we 
already know the values in this case. 

           Step 1 In the Increment menu, click on Define In Situ Stress Conditions... to 
display the In Situ Stress Setup dialogue box. 
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Figure  3-9:In Situ Stress dialogue box 

           Step 2 Enter the values as shown below in Figure  3-9. 

           Step 3 Click on OK to exit once you have finished. 

3.3.7 Defining Increment Blocks 
Increments are the units by which the finite element program advances the analysis.  In each increment, 
the effect of applied load and boundary conditions is calculated and the accumulated strains and pore 
water pressures are updated.  Increments are grouped together in blocks which then model particular 
events in the analysis. 

This analysis requires only one increment block.  This models the application of a prescribed 
displacement.  The block comprises 6 increments. 

           Step 1 In the Increment menu, click on Define Increment Block Parameters... to 
display the Increment Block Information dialogue box. 

 
Figure  3-10:Increment Block dialogue box 
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           Step 2 A default block called ‘Increment Block (untitled)’ is automatically created 
because no other blocks exist. Change the name  to “Triaxial Loading” in the 
Description of Block text box. 

Tip As mentioned in Section  �2-2, 6 increments are insufficient for the 
problem being analysed.  If you prefer, you may enter 50 increments here, 
but the penalty is that the finite element analysis will take longer to run. 

           Step 3 Click on the Define... button.  This displays the Define Load/Time Steps 
dialogue box. 

 
Figure  3-11:Defining Load and Time Steps 

           Step 4 Select Equal in the Load Options group box.  The Define Load/Time Steps 
dialogue box should now look like Figure  3-11.  Click on OK to return to the 
Increment Block Information dialogue box, once you have finished. 

           Step 5 Click on OK to exit. 

3.3.8 Defining Boundary Conditions 
Boundary conditions describe to the finite element analysis, the ways in which the mesh is physically 
restrained from moving.  This is achieved by applying fixities to edges and nodes in the mesh. 

Once defined, fixities apply in all successive increment blocks.  The Fixities dialogue box and the 
Graphics Window (if View Fixities is toggled on) will only display any fixity that is applied during the 
current increment block. 

For this example, boundary conditions need to be applied to both the in situ stage and to the triaxial 
loading stage. 

The following procedure defines the fixities for the in situ stage. 

           Step 1 Ensure that ‘In situ’ is selected from the increment block list box on the main 
toolbar. 

           Step 2 In the Select menu, click on Edges. 

           Step 3 Select the bottom (horizontal) edge of the mesh by clicking on it. 

           Step 4 In the Increment menu, click on Fixities... to display the Edge Fixity (Group) 
dialogue box. 
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           Step 5 Click on the Y displacement fixity option and type “0” into the Start Node 
and Finish Node text boxes.  Now set the mid-side fixity to zero by either 
pressing the Interpolate button or by typing in “0” directly. 

           Step 6 The Edge Fixity dialogue box should look like Figure  3-12.  Click on OK to exit 
once you have finished. 

 
Figure  3-12:Zero Y displacement Fixities 

           Step 7 In the Select menu, click on Clear Selection to ensure that no edges remain 
selected (Select Edge is still active).  Then select the left-hand (vertical) edge of 
the mesh by clicking on it. 

           Step 8 In the Increment menu, click on Fixities... and define the fixity as before except 
as zero X displacement fixities rather than zero Y displacement fixities. 

           Step 9 Click on OK to exit once you have finished and click on the left-hand edge of 
the mesh to de-select it. 

           Step 10 The Graphics Window should now look similar to Figure  3-13. 
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Figure  3-13:Displacement Fixities at the In Situ Stage 

In this example the only fixity that alters during the test is the top edge, which undergoes a prescribed 
displacement of -0.03m. The following procedure defines this fixity in the triaxial loading stage. 

           Step 11 Select ‘Triaxial Loading’ from the increment block list box on the main toolbar. 

           Step 12 Select the top (horizontal) edge of the mesh by clicking on it. 

           Step 13 In the Increment menu, click on Fixities... to display the Edge Fixity dialogue 
box. 

 
Figure  3-14:Defining a Displacement 

           Step 14 Click on the Y displacement fixity option and enter the value “-0.03” into the 
Start Node and Finish Node text boxes.  Pressing the Interpolate button 
automatically enters the Mid Value as -0.03.  Alternatively you can enter it 
manually. 
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           Step 15 The Edge Fixity dialogue box should now look like Figure  3-14.  Click on OK 
to exit once you have finished. 

3.3.9 Defining Loads 
A load is applied to the right-hand edge of the mesh to simulate the cell pressure.  As with fixities, once 
defined loads apply in all successive increment blocks.  The Loads dialogue box and the Graphics 
Window (if View Loads is toggled on) will only display any load that is applied during the current 
increment block. 

           Step 1 Select ‘In situ’ from the increment block list box on the main toolbar. 

           Step 2 In the Select menu, click on Clear Selection to ensure no edges are selected. 

           Step 3 Select the right-hand (vertical) edge of the mesh and the top (horizontal) edge by 
clicking on them. 

           Step 4 In the Increment menu, click on Loads... to display the Edge Load dialogue 
box. 

           Step 5 Enter a value of 150 kN/m2 in the Normal Start node and Normal Finish 
node text boxes.  Click on the Interpolate button and the Mid Value will 
automatically be entered as 150 kN/m2.  Alternatively the value can be entered 
manually. 

           Step 6 The Edge Load dialogue box should now look like Figure  3-15.  Click on OK to 
exit once you have finished. 

 
Figure  3-15:Defining a Triaxial Cell Pressure 

3.3.10 Scale Factors 
Loads are displayed on the Graphics Window as arrows whose length is proportional to the size of the 
load.  In order to optimise the display of these arrows, a scaling factor can be specified that will increase 
or decrease the length of every load arrow in the mesh by the same proportion. 

Customising the display of loads in this way takes three forms - Shear load scale, Normal load scale 
and Offset from the line to which the loads apply. 

           Step 1 In the Options menu, click on Default Settings... to display the Defaults 
dialogue box. 
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Figure  3-16:The Defaults dialogue box 

           Step 2 Click on the Scale Factors tab. 

           Step 3 Enter a value of 0.001 in the Normal text box. 

           Step 4 The Defaults dialogue box should look like Figure  3-16.  Click on OK to exit 
once you have finished. 

           Step 5 In the View menu, click on Loads (a tick will appear to the left of the item 
when it is selected). 

           Step 6 The Graphics Window should now look similar to Figure  3-17. 

 
Figure  3-17:Loads and Fixities at In Situ Stage 
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3.3.11 Running The Analysis 
You should save the Project now.  This concludes the pre processing for this particular problem so all that 
remains is for you to run the finite element analysis program. 

           Step 1 In the File menu, click on Run Analysis... to run the finite element analysis.  
This displays the Run Analysis dialogue box. 

 
Figure  3-18:The Run Analysis dialogue box 

           Step 2 Click on Create CRISP Files Now.  This will write two files with the 
extensions .GPS and .MPS to disk.  These files contain the input data required by 
the finite element analysis program. 

           Step 3 Click on Run Analysis Now.  This will task switch you to a DOS box and 
will run the finite element program using the data files just created. 

           Step 4 When the analysis is finished, you will be returned to Windows and the output 
from the analysis is converted into a Microsoft Access 2.0 database.  A 
percentage bar informs you as to how long you have left to wait. 

           Step 5 The Post-Processor is loaded as soon as the conversion is complete and you can 
begin to look at your results. 

3.4 Post Processing 
In this section you will be introduced to the following features: 

 Duration Graphs 

 Displacement Plots 

3.4.1 Introduction 
If you entered the Post-Processor directly from running the analysis, your Project will already be loaded.  
However you may also enter the Post-Processor by double-clicking on its icon in the CRISP2D program 
group in Windows’ Program Manager.  In this case, you should select Open Project... from the File 
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menu and, provided the analysis has been successfully run, you will be able to post process the output 
from your analysis. 

For this example, ensure that you have the Parent Project loaded in the Post-Processor. 

3.4.2 Duration Graphs 
Duration graphs allow you to investigate the variation of output from individual integration points or 
nodes over the course of a specified range of increments. 

Up to 10 data sets (each one representing a different integration point or node) can be viewed on the same 
graph, but for these examples a single integration point will be used. 

Three graphs will be plotted: 

 Deviatoric Stress against Mean Normal Effective Stress (q-p’) 

 Deviatoric Stress against Deviatoric Strain (q-Dev. Strain) 

 Total Pore Pressure against Deviatoric Strain (u-Dev.Strain) 

The graph of Deviatoric Stress against Mean Normal Effective Stress is created as described by the 
following procedure: 

           Step 1 Click on Integration Points and then on Clear Selection in the Select  
menu.  Select an integration point in the top right corner of the mesh by clicking 
on it. 

           Step 2 In the Plots menu, click on Duration Graphs... to display the Duration Graph 
dialogue box. 

 
Figure  3-19 :Duration Graph dialogue box 

           Step 3 Click on the New button to create your graph and change the title to ‘IP Stress 
Graph’. 

           Step 4 Ensure that the Increment Range starts at 1 and finishes at 6. 
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           Step 5 Click on the q - p’ button.  This automatically enters Mean Normal Effective 
Stress (PE) as X Axis data and Deviatoric Stress (Q) as Y Axis data.  The 
Duration Graph dialogue box should now look like Figure  3-19. 

           Step 6 Click on OK to exit once you have finished.  The graph displayed should look 
similar to Figure  3-20.  You can configure the way the graph looks (axis labels, 
titles and legend) by double-clicking on the graph window and changing the set-
up in the Graph Configuration dialogue box. 

 
Figure  3-20::Integration Point Stress Graph 

The Integration Point that was used for the first Duration Graph remains selected after the first plot is 
created and can be used to create further graphs. 

The graph of Deviatoric Stress against Deviatoric Strain is created as described by the following 
procedure: 

           Step 7 In the Plots menu, click on Duration Graphs... to display the Duration Graphs 
dialogue box. 

           Step 8 Click on the New button to create your graph and change the title to ‘IP 
Stress/Strain Graph’. 

           Step 9 Ensure that the Increment Range starts at 1 and finishes at 6. 

           Step 10 Click on the “ q - Dev. Strain ” button.  This automatically enters Deviatoric 
Strain (EPS) as X Axis data and Deviatoric Stress (Q) as Y Axis data. 

           Step 11 Click on OK to exit once you have finished.  The graph displayed should look 
similar to Figure  3-21.  You can configure the way the graph looks (axis labels, 
titles and legend) by double-clicking on the graph window and changing the set-
up in the Graph Configuration dialogue box. 
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Figure  3-21:Integration Point Stress/Strain Graph 

The third graph of Total Pore Pressure against Deviatoric Strain is created as described by the following 
procedure: 

           Step 12 In the Plots menu, click on Duration Graphs... to display the Duration Graph 
dialogue box. 

           Step 13 Click on the New button to create your graph and change the title to ‘IP Pore 
Pressure/Strain Graph’. 

           Step 14 Ensure that the Increment Range starts at 1 and finishes at 6. 

           Step 15 Click on the “ u - Dev. Strain ” button.  This automatically enters Deviatoric 
Strain (EPS) as X Axis data and Total Pore Pressure as Y Axis data. 

           Step 16 Click on OK to exit once you have finished.  The graph displayed should look 
similar to Figure  3-22.  You can configure the way the graph looks (axis labels, 
titles and legend) by double-clicking on the graph window and changing the set-
up in the Graph Configuration dialogue box. 
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Figure  3-22 :Integration Point Pore Pressure/Strain Graph 

3.4.3 Displacement Plots 
Displacement plots are drawn directly onto the Graphics Windows.  They provide a representation of how 
the mesh has deformed at any stage in the analysis.  You can view either vector displacements or the 
deformed mesh at any specified magnification. 

           Step 1 Select Displacement Plots... from the Plots menu.  This displays the 
Displacement Plot dialogue box. 

 
Figure  3-23 :Displacement Plot dialogue box 

           Step 2 Click on the New button to create your plot and change the title to ‘Fully 
deformed mesh’. 
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           Step 3 Select the Deformed Mesh option. 

           Step 4 Ensure that Incremental is selected, that the Start increment is 1 and the Finish 
increment is 6. 

           Step 5 Enter a Magnification Factor of 5.  The Displacement Plot dialogue box will 
then appear as shown in Figure  3-23. 

           Step 6 Click on OK to exit once you have finished.  The plot will be displayed on the 
Graphics Window.  Once a zoom window has been executed to view the area of 
interest, the plot will appear as shown in Figure  3-24. 

 
Figure  3-24:Deformed Mesh Plot 

3.5 Summary 
By the end of this example you will have made use of the following features: 

 Cam clay 

 Duration graphs 

 Displacement plots 

3.6 Things To Try Next 
 If you look at the analysis summary it can be seen that the yield ratios for 

increment 2 are unacceptably high.  This is a good indicator that the are not 
enough increments in the analysis.  Increase the number of increments to 50 and 
compare the results.  Note - 50 increments will give the theoretical solution. 



 Introduction 

4 STRIP FOOTING ON 
GIBSON SOIL  

4.1 Introduction 
This example is designed to introduce you to the automatic mesh generation feature (using the structured 
mesh generator) and to the use of the Parent/Child feature to carry out a parametric study.  This feature is 
used to compare results from the finite element analysis with results predicted by theory.  The subject of 
the example is a strip footing on an elastic soil, with linear variation of shear modulus with depth. 

The following steps will be covered: 

 Starting The Project 

 Defining Units 

 Creating The Finite Element Mesh 

 Defining A Material Zone 

 Assigning Element Properties 

 Defining In Situ Stress Conditions 

 Defining Increment Blocks 

 Defining Boundary Conditions 

 Defining Loads 

 Scale Factors 

 Running The Analysis 

 Displacement Plots 

 Duration Graphs 
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4.2 The Problem 

 
Figure  4-1:Strip Footing Geometry 

Figure  4-1 shows the mesh and the soil data for a plane strain calculation of the settlement of a strip load 
on Gibson soil. 

The Gibson soil is an elastic material in which the shear modulus increases linearly with depth.  Using z to 
denote depth, the shear modulus (G) is given by: 

G z= ⋅α  

This can be related to Young’s modulus using the equation: 

( )E G= +2 1 ν  

The material is then defined by inputting a value of E at the top of the mesh (E0) of zero and calculating 
the gradient of variation of Young’s modulus with depth. 

An exact solution to this problem is only available for the case of a Poisson’s ratio of 0.5.  In this example 
a value of 0.49 is used in order to approximate this incompressibility condition. 

Taking a value of 80 kN/m2/m for α yields the gradient, m: 

( )E z

E z

m E
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The results from this example show an almost uniform settlement of the soil surface beneath the strip 
load, as can be seen if you produce a deformed mesh plot or contour vertical displacements using the 
Post-Processor. The observed settlement is 0.0598 m at the centre of the strip load. 

The analytic solution is exact only for an infinite half-space, whereas the solution obtained here is for a 
layer of finite depth.  However, the effect of a shear modulus that increases linearly with depth is to 
localise the deformations near the surface;  it would therefore be expected that the finite thickness of the 
layer will only have a small effect on the results.  The exact solution for this particular problem, as given 
by Gibson1, gives a uniform settlement beneath the load of magnitude: 

 
1 Gibson, R.E. (1967), Some results concerning displacements and stresses in a non-homogeneous elastic half-space, 
Geotechnique, Vol 17, 58-64. 
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Settlement = P
2α

 

where 

P = pressure load per unit length  

In this case, the exact solution gives a settlement of 0.0625 m and the finite element analysis gives a result 
of 0.0598 m. 

4.3 Pre-Processing 
This section describes all of the stages that must be completed using the Pre-Processor in order to run the 
finite element analysis.  It is recommended that you save the Project regularly (by clicking on Save in the 
File  menu). 

4.3.1 Starting The Project 
This section describes the basic processes that should be completed in advance of creating your mesh. The 
steps you will follow include: 

 Selecting a mesh mode 

 Entering Project set-up information 

 Entering QA information 

 Verifying the base units system 

 Activating autosave 

 Defining a background grid 

 Choosing a background colour 

Selecting A Mesh Mode 
The first thing that you are asked to do when you start a new Project is to select a starting mesh mode.  
This means that you must decide whether you want to create the finite element mesh using either the 
structured or the unstructured automatic mesh generators, or if you want to create it directly. 

This example involves generating a finite element mesh from a structured super mesh. 

           Step 1 On opening the CRISP2D Pre-Processor, select New Project... from the File  
menu.  This displays the Mesh Mode dialogue box: 
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Figure  4-2 :Mesh Mode dialogue box 

           Step 2 Click on the Structured Super Mesh button.  This exits the Mesh Mode 
dialogue box, sets you up in Structured Super Mesh mode and opens the Project 
Setup dialogue box. 

Setting Up The Project 
Setting up a Project involves defining the analysis type, specifying whether or not the mesh is to be 
composed of cubic strain triangles and setting up various run-time options. 

           Step 1 In the Domain Type section, click on the Plane Strain option button and click 
on All Other Elements in the Element Type section. 

           Step 2 Enter an in situ gravity level of 1 G. 

           Step 3 The Project Setup dialogue box should now look similar to Figure  4-3. 

 
Figure  4-3:Project Setup dialogue box 

Entering Quality Assurance Information 
           Step 1 Click on the Info... button in the Project Setup dialogue box. This displays the 

Project Information dialogue box.  This contains fields for you to enter QA 
information such as job number, operator name, checker name, etc. 
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Figure  4-4:Project Information dialogue box 

           Step 2 Enter data as appropriate.  The date is automatically entered but may be 
manually altered. 

           Step 3 The Project Information dialogue box should now look similar to Figure  4-4.  
Click on OK to return to the Project Setup dialogue box once you have finished. 

           Step 4 Click on OK to exit. 

Defining Units 
At this early stage it is useful to ensure that the correct system of base units is being used. 

           Step 1 In the Options menu, click on Units... to display the Units dialogue box. 

 
Figure  4-5:Units dialogue box 

           Step 2 Use the list boxes to select the appropriate units for Distance, Force, Time and 
Angle as shown in Figure  4-5.  Click on OK to exit, once you have finished. 

Autosaving 
This is an opportune moment to introduce the Autosave feature.  If for any reason you lose your Project (it 
happens!) you need not worry about having to start all over from scratch, or even from when you last 
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saved.  Autosave creates a backup copy of your Project at definable time intervals that will be 
automatically restored in the event of an unexpected exit. 

To activate Autosave, follow this procedure: 

           Step 1 Click on Default Settings... in the Options  menu to display the Defaults 
dialogue box, and click on the Load/Save tab. 

 
Figure  4-6:Load/Save Defaults dialogue box 

           Step 2 Click on the Browse button, which displays the Load/Save Path dialogue box. 

           Step 3 Select the drive and directory where your backup copies will be stored and click 
OK to exit, once you have finished. 

           Step 4 Click on the Autosave checkbox.  This enables the spin control so that you can 
define how often your Project is saved. 

           Step 5 Adjust the spin control to read 5 minutes.  The Defaults dialogue box should 
now look similar to Figure  4-6.  Click on OK to exit, once you have finished. 

           Step 6 In the File menu, click on Save.  This brings up a standard Windows File Save 
dialogue box.  CRISP2D Projects are stored with a .SCD extension. 

Defining A Background Grid 
A Background Grid feature is provided as an aid to drawing regular meshes.  Two types of grid are 
available: an ordinary fixed grid, such as is used in this example and an auto grid.  The fixed grid allows 
you to specify the physical distance between one grid point and the next according to the base units of 
length that you have chosen (in this case, metres). 

Warning Using the fixed grid, if you zoom out too far the screen will become 
completely overcrowded with grid points.  Any actions you then attempt to 
make will be very slow because of the shear volume of data being 
displayed on the Graphics Window. 

 The Autogrid feature is designed to avoid this problem.  Instead of 
showing grid points a set distance apart it allows you to specify the 
maximum number of points you want to see on the screen in the X and Y 
directions.  A scale is then displayed at the borders of the Graphics 
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Window to help you keep track of the physical distance that separates 
these points. 

           Step 1 Click on Grid... in the Options  menu or double click on the word ‘GRID’ at the 
bottom of the Graphics Window.  This displays the Grid Options dialogue box. 

 
Figure  4-7 :Grid Options dialogue box 

           Step 2 Select Fixed Grid and enter the X spacing as 5 and the Y spacing as 10. 

           Step 3 The dialogue box should now look like Figure  4-7.  Click on OK to exit, once 
you have finished.  The Graphics Window will then display a grid of dark grey 
dots. 

Changing The Background Colour 
The fixed grid can be difficult to see if the background of the Graphics Window is grey, so it is useful to 
be able to change this colour.  To change the background colour, follow this procedure: 

           Step 1 Click on Colour in the Options menu. 

           Step 2 Click on white in the background selection frame 

           Step 3 Click on OK to exit. 

4.3.2 Creating A Mesh Using The Structured Mesh 
Generator 

The Super Mesh provides a simple method of generating large numbers of finite elements.  In this 
example 60 finite elements are automatically created from a super mesh comprising just 2 super elements.  
This saves an enormous amount of time and effort. 

This section covers all of the stages you must have completed in order to automatically generate the finite 
element mesh.  The steps you will follow include: 

 Drawing A Super Mesh 

 Defining Edge Gradings 
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 Defining A Material Zone 

 Assigning Element Properties 

 Generating The Finite Element Mesh 

Drawing The Super Mesh 
The mesh of Super Elements is drawn directly onto the Graphics Window using a combination of mouse 
point-and-click actions and keystrokes.  These combinations are summarised below: 

 To position the vertex of a Super Element you must hold the CTRL key down and 
left click on the Graphics Window at the point where you wish to locate the 
vertex.  These vertexes are termed Super Nodes. 

 By holding down both SHIFT and CTRL when you left click, the cursor snaps to 
the nearest grid point and creates a new Super Node.  This facilitates the design 
of rectilinear meshes. 

The following procedure should be strictly followed in order to create the Super Mesh: 

           Step 1 In the Mesh menu, click on Create Super Elements.  The fact that you can 
now create elements is indicated by the mode box in the status bar at the bottom 
of the screen. 

           Step 2 Select ‘Window’ from the Zoom list box on the main toolbar. 

           Step 3 With the cursor located over a point about 3/4 of the way down the screen and 
1/6 of the way in from the left (over the top left corner of the black box in 
Figure  4-8), press the right mouse button.  Holding the right button down, move 
the mouse to size the zoom window.  Release the button when you have 
highlighted the area you wish to magnify.  The Graphics Window should briefly 
look similar to Figure  4-8, before you release the button.  Note that the zoom 
window may look different depending on your default configuration. 
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Figure  4-8:Using Zoom Window to Move Around the Graphics Window 

           Step 4 Whilst holding down both the CTRL and the SHIFT keys, click close to the origin 
(indicated by the co-ordinates on the status bar) to create the first node at (0 , 0). 

           Step 5 Continue clicking on the Graphics Window to place the vertex nodes of the 
Super Elements.  Figures a to j depict the entire process of creating the Super 
Mesh.  Remember to hold down CTRL and SHIFT when you are creating new 
nodes (Figures a, b, c, d, g and h), but to release them when you wish to use an 
existing node (Figures e, f, i and j). 

 

a. 

 

b. 

 
c. 

 

d. 
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e. 

 

f. 

 
g. 

 

h. 

 
i. 

 

j. 

 
 

           Step 6 In the Edit menu, click on Commit Super Element Creation. This fixes the 
elements, confirming that they are correctly created.  The elements will change 
colour when they committed. 

           Step 7 To verify that you have correctly positioned all of the nodes, click on Super 
Node List... in the Mesh menu.  This displays the Super Node List dialogue 
box. 
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Figure  4-9:Co-ordinates of Super Nodes 

           Step 8 If any of your entries are different to those shown in Figure  4-9, click on the 
number(s) you need to change and type in your amendment(s).  You can check 
your progress by clicking on the Preview button. 

           Step 9 If you have made any changes you should exit by clicking on OK.  Otherwise 
you can click on Cancel or press ESC to exit. 

Defining Edge Gradings 
Edge Gradings define how the Super Elements will be divided up into finite elements by the mesh 
generator.  In general, better results will be obtained by using smaller finite elements in the parts of the 
mesh that experience the most rapid and/or the largest changes in stress, during the course of the analysis. 

           Step 1 In the Select menu, click on Super Edges.  Select the top left-hand 
(horizontal) edge of the mesh by clicking on or close to it. 

           Step 2 In the Mesh  menu, click on Super Edge Grading... to display the Super 
Edge Gradings dialogue box. 
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Figure  4-10:Defining Edge Gradings for the Top Left-Hand Edge 

           Step 3 Enter ‘3’ into the Number of Divisions text box and click on the Equal 
Spacing option.  Weighting values will be automatically entered and the 
dialogue box should now look like Figure  4-10. 

           Step 4 Click on OK to exit, once you have finished. 

           Step 5 In the Select menu, click on Clear Selection, or click again on the selected 
edge to de-select that edge.  Click on the top right-hand (horizontal) edge.  When 
an edge is selected, one or other of that edge’s nodes is also highlighted.  Ensure 
that the highlighted node is the one on the left-hand end of the edge by clicking 
closer to this end than the other when you select the edge.  If the wrong node is 
highlighted, your gradings will appear the wrong way around. 

           Step 6 In the mesh menu, click on Super Edge Grading... to again display the 
Super Edge Gradings dialogue box. 
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Figure  4-11:Defining Gradings for the Top Right-Hand Edge 

           Step 7 Enter a value of ‘3’ into the Number of Divisions and Factor (k) text boxes. 

           Step 8 Click on the End 1 is k times End 2 option.  The dialogue box should now 
look like Figure  4-11. 

           Step 9 Click on OK to exit, once you have finished. 

           Step 10 In the Select  menu, click on Clear Selection. 

           Step 11 Select the left-hand vertical edge, ensuring that the node at the top is highlighted. 

           Step 12 Apply edge gradings to this edge, such that there are 5 divisions, with the 
division at the bottom of the edge being 3 times larger than the division at the 
top.  The dialogue box should look like Figure  4-12. 
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Figure  4-12:Defining Gradings for the Left-Hand Vertical Edge 

           Step 13 Click on OK to exit, once you have finished. 

           Step 14 Opposite edges of each element are always graded in identical proportions, so by 
defining gradings for just these three edges, all edges in the mesh have been 
graded.  This can be seen from the Graphics Window, which should now look 
similar to Figure  4-13. 
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Figure  4-13:Fully Assigned Edge Gradings 

Defining A Material Zone 
A Material Zone contains information about the soil model and associated soil parameters that are being 
used to model  particular regions of the mesh. 

It is necessary to define the number of material zone(s) at this point in order to be able to allocate them 
using the Element Properties dialogue box (the next stage). 

Once you have set up a zone, the soil model and parameters may be entered or changed at any time prior 
to the analysis being run. 

           Step 1 Select Material Properties... from the Mesh  menu.  This displays the 
Material Properties dialogue box. 
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Figure  4-14:Material Properties dialogue box 

           Step 2 Enter the name ‘Gibson soil’ and select ‘Elastic (Linear variation with depth)’ 
from the Soil Model list box.  Material zones are referenced by name elsewhere 
in the Project, so it is good practice to give each zone a meaningful title here. 

           Step 3 Enter the following material property values: 

Property Value Units 

E0 0 kN/m2 

Y0 20 m 

m 238.4 kN/m2/m 

ν 0.49 None 

Kw / γw  0 kN/m3 

γbulk 20 kN/m3 

kx 0 m/sec 

ky 0 m/sec 

 

           Step 4 The Material Properties dialogue box should now look similar to Figure  4-14.  
Click on OK to exit, once you have finished. 

Tip Although values for the soil properties have been defined here, it is 
possible to delay defining them right up until just before you run the 
analysis. 

Assigning Element Properties 
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Every element in the mesh has two properties associated with it:  

 Finite element type, and 

 Material zone 

These properties are assigned to finite elements in the following manner: 

           Step 1 In the Select menu, click on Domain Super Elements and select both 
elements by clicking on them. 

           Step 2 In the Mesh menu, click on Element Properties... to display the Element 
Properties dialogue box. 

 
Figure  4-15:Defining Element Type and Zone 

           Step 3 Select the Linear Strain Triangle (non consolidating) option. 

           Step 4 Select ‘Gibson soil’ from the Material Zone list box. 

           Step 5 The Element Properties dialogue box should now look like Figure  4-15.  Click 
on OK to exit, once you have finished. 

Generating The Finite Element Mesh 
You are now at a stage where you can generate the finite element mesh from your Super Mesh. 

           Step 1 In the Mesh menu, click on Generate Finite Element Mesh.  This will first 
check that you have correctly graded every edge and that you have assigned a 
generated finite element type to each super element.  It will then spend a short 
time performing the automatic generation of the finite element mesh. 

           Step 2 Provided you have completed the above stages correctly, the finite element mesh 
will be displayed as shown in Figure  4-16.  The menu bar will now allow you 
access to the additional options available in Finite Element Mesh mode. 
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Figure  4-16:Automatically Generated Finite Element Mesh 

4.3.3 Defining In Situ Stresses Using The In Situ 
Stress Convertor 

In situ conditions are defined in terms of stresses at different elevations within the mesh.  These stresses 
are derived from soil parameters that are obtained (almost) directly from lab testing of your particular soil. 

The derivations can either be performed by hand, in which case you enter the values directly into the In 
Situ Stress Setup dialogue box, or you can use the Stress Conversion Parameters dialogue box to 
automatically perform the derivation for you. 

The latter method requires you first to select the reference elevation for which you wish to calculate the 
stresses.  You can then input the soil parameters and perform the automatic derivation. 

           Step 1 In the Increment menu, click on Define In Situ Stresses... to display the In 
Situ Stress Setup dialogue box. 
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Figure  4-17:In Situ Stress Setup dialogue box 

           Step 2 Select the second row of the in situ stresses grid by clicking on the row number 
(to the left of the Height column).  This enables the Convert Height... button, 
which you should click on to display the Stress Conversion Parameters dialogue 
box. 

 
Figure  4-18:Using the In Situ Stress Convertor 

           Step 3 Enter values as shown in Figure  4-18.  Click on OK to exit, once you have 
finished.  The stress convertor takes these parameters , converts them into 
stresses and enters them into the highlighted row in the in situ stresses grid. 

           Step 4 The In Situ Stress Setup dialogue box should now look like Figure  4-17.  Click 
on OK to exit. 

4.3.4 Defining Increment Blocks 
Increments are the units by which the finite element program advances the analysis.  In each increment, 
the effect of applied loads and boundary conditions is calculated and the accumulated strains and pore 
water pressures are updated.  Increments are grouped together in blocks which then model particular 
events in the analysis. 

This analysis requires only one increment block during which the strip load is applied to the mesh.  The 
block comprises 10 increments. 
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           Step 1 In the Increment menu, click on Define Increment Block Parameters... to 
display the Increment Block dialogue box. 

 
Figure  4-19 :Defining Increment Blocks 

           Step 2 A default increment block is created when you enter this box for the first time.  
In the Description of block text box, change the name of the block from 
‘Increment Block (untitled)’ to ‘Apply strip load’. 

           Step 3 Allocate ten increments to the block. 

           Step 4 Since this is a non-consolidation analysis, any time-step specified for the block 
will be ignored. 

           Step 5 Click on OK to exit. 

4.3.5 Defining Boundary Conditions 
Boundary conditions describe to the finite element analysis the ways in which the mesh is physically 
restrained from moving.  This is achieved by applying fixities to edges and nodes in the mesh. 

Once defined, fixities apply in all successive increment blocks.  The Fixities dialogue box and the 
Graphics Window (if View Fixities is toggled on) will only display any fixity that is applied during the 
current increment block. 

In this example, the left and right edges are restrained horizontally and the base is restrained both 
horizontally and vertically. 

The following procedure defines fixities for the in situ stage: 

           Step 1 Select ‘In situ’ from the Increment Block list box on the main toolbar. 

           Step 2 In the Select menu, click on Edges. 

           Step 3 Select all of the vertical edges on the left and right-hand sides of the mesh by 
clicking on them.  All of these edges have zero X direction fixities, so they can 
be defined simultaneously. 
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           Step 4 In the Increment menu, click on Fixities... to display the Edge Fixity dialogue 
box. 

 
Figure  4-20:Defining Edge Fixities 

           Step 5 Click on the X displacement option button. 

           Step 6 Specify X direction fixities by typing ‘0’ into the Start Node and Finish 
Node text boxes.  Now set the Mid-Value fixity to zero by either pressing the 
Interpolate button or by typing in ‘0’ directly. 

           Step 7 The Edge Fixity dialogue box should now look like Figure  4-20.  Click on OK 
to exit, once you have finished. 

           Step 8 The Graphics Window should look similar to Figure  4-21.  If no fixities are 
visible, click on Fixities in the View menu (a tick will appear to the left of the 
item when it is active). 

 
Figure  4-21:Fixities Defined for the Left and Right Vertical Sides 
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           Step 9 Click on Clear Selection in the Select  menu to ensure that no edges are 
selected (note that Select Edge mode remains active).  Then select the bottom 
(horizontal) edges of the mesh by clicking on them. 

           Step 10 In the Increment menu, click on Fixities... and define zero X displacement 
fixities as before. 

           Step 11 Click on the Y displacement option button. 

           Step 12 Specify Y direction fixities of zero in the Start Node, Finish Node and Mid-
Value text boxes. 

           Step 13 Click on OK to exit, once you have finished.  The Graphics Window should 
look similar to Figure  4-22. 

 
Figure  4-22:In Situ Fixities Fully Defined 

4.3.6 Defining Loads 
A load is applied to edges along the left-most 5m of the top of the mesh to simulate the strip footing.  As 
with fixities, once defined, loads apply in all successive increment blocks.  The Loads dialogue box and 
the Graphics Window (if View Loads is toggled on) will only display any load that is applied during the 
current increment block. 

The sign conventions that apply to pressure loads are: 
Positive loads are displayed pointing towards the bottom left corner 
of the Graphics Window. 

This convention is enforced as follows: 
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 Downwards is positive; 

 Right-to-left is positive; 

 When applied to inclined edges, the downwards positive criterion takes 
precedence over right-to-left; 

 When applied to vertical edges, right-to-left is positive. 

For further clarification, see Section 5.9.5 in the User Guide.  The following procedure defines loads for 
this problem. 
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           Step 1 Select ‘Apply strip load’ from the Increment Block list box on the main toolbar. 

           Step 2 Click on Clear Selection in the Select  menu to ensure no edges are selected. 

           Step 3 Select the edges of the mesh that correspond to the top edge of the first super 
element you created.  On the finite element mesh these are the first three edges 
along horizontally from the top left-hand corner. 

           Step 4 In the Increment menu, click on Loads... to display the Edge Load dialogue 
box. 

           Step 5 Enter a value of 10 kN/m2 in the Normal Start node and Normal Finish 
node text boxes.  Click on the Interpolate button and the Normal Mid 
Value will automatically be entered as 10 kN/m2.  Alternatively the value can 
be entered manually. 

           Step 6 The Edge Load dialogue box should now look like Figure  4-23.  Click on OK to 
exit, once you have finished. 

 
Figure  4-23:Defining the Strip Load 

           Step 7 Once you have finished, the Graphics Window should look something like 
Figure  4-24.  Here, the loaded region has been magnified using the Zoom 
Window feature.  The appearance of the load arrows can be modified by 
changing the default scale settings (see section  4.3.7). 
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Figure  4-24:Strip Load Applied at the Top of the Mesh 

4.3.7 Scaling The Displayed Load Arrows 
Loads are displayed on the Graphics Window as arrows whose length is proportional to the size of the 
load.  If the load arrows on the screen look too long or too short, you can adjust this using the Scale 
Factors function. 

           Step 1 In the Options menu, click on Default Settings... to display the Defaults 
dialogue box. 

 
Figure  4-25:Scale Factors for Strip Footing Loads 

           Step 2 Click on the Scale Factors tab. 

           Step 3 Enter values of 0.2 in the Normal text box and 0.1 in the Offset text box. 

           Step 4 The Defaults dialogue box should now look similar to Figure  4-25.  Click on 
OK to exit, once you have finished. 
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4.3.8  Setting Up A Parent/Child Analysis 
In order to be able to compare results from two separate runs of the finite element analysis, the Project 
must be turned into a Parent Project and a number of Child Projects. 

A Child Project is initially a copy of the original (Parent) Project.  The mesh cannot be altered but features 
such as material properties and number of increments may be varied. 

Due to the choice of the elastic soil model, the number of increments used should not increase the 
accuracy of the analysis.  To demonstrate this a Child Project is made with just 5 increments (remember 
that the Parent has 10 increments). 

           Step 1 The Project must be saved before any Child Projects can be created.  Click on 
Save Project in the File menu to save your Project to disk. 

           Step 2 In the File menu, click on Parent/Child... to display the Parent/Child dialogue 
box. 

           Step 3 Enter the name ‘Stripft2’ into the New Child Name text box.  This will be the 
filename of the  Child Project and is therefore restricted to 8 characters. 

           Step 4 Click on the  button to assign it to the family tree.  This creates an 
identical Project to the one you currently have open with the filename you just 
assigned to it.  The Parent/Child dialogue box should look similar to Figure  4-26. 

 
Figure  4-26:Setting Up A Parent-Child Relationship 

           Step 5 Make sure that the new child Project is highlighted in the Family Tree list and 
click on Load.  This will exit the Parent And Children dialogue box and load 
the new child into the Pre-Processor. 

           Step 6 Select Define Increment Block Parameters... from the Increment  menu 
and change the number of increments in the ‘Strip Loading’ block to 5. 

           Step 7 This concludes the set-up of the child analysis. 

4.3.9 Running The Analysis 
The Project should now be saved.  Provided you have followed all of the steps described above, 
preparation of the Project using the Pre-Processor is complete. 

Since there are two Projects to run, it is convenient to use the Batch Run utility.  This allows you to line 
up a series of Projects that will be run consecutively.  The sequence of events is outlined below. 
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 Creating The Output Files 

 Setting Up A Batch Run 

 Performing The Analysis 

Creating Output Files 
The first stage is to create the output files for the two Projects.  The following procedure describes how 
this is done (it assumes that you still have the Child Project loaded). 

           Step 1 In the File menu, click on Run Analysis... to display the Run Analysis 
dialogue box. 

 
Figure  4-27:Run Analysis dialogue box 

           Step 2 Click on the Create CRISP Files Now button.  Provided you have followed 
all of the above steps correctly, this will create .GPR and .MPD files for your 
Project.  A message box will appear after each stage has been completed. 

           Step 3 Click on Exit once you have finished. 

           Step 4 In the File menu, click on Parent/Child... to display the Parent/Child dialogue 
box. 

           Step 5 Highlight the Parent Project in the Family Tree list and load it. 

           Step 6 Create the CRISP output files as described above and press Exit once you have 
finished. 

           Step 7 By now you should have created output files for both the Parent and Child 
Projects. 

Setting Up A Batch Run 
A Batch run is simply a list of Projects that are to be run consecutively.  The following steps describe how 
to set up a Batch run to carry out the Parent and Child analyses in this way: 
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           Step 1 In the File menu, click on Setup Batch Run... to display the Setup Batch Run 
dialogue box. 

           Step 2 Change to the drive and directory in which the Projects are saved.  When you are 
in the correct directory, the names of both the Parent and Child Projects should 
appear in the Analysis Names list. 

           Step 3 Highlight these two files and click on Add to add them to the Files to run list. 

           Step 4 Click on Save Batch File As... to display the standard Windows File Save 
dialogue box. 

           Step 5 Give the batch file a name (with a .SBF extension) and click on OK to return to 
the Setup Batch run dialogue box. 

           Step 6 Click on Exit once you have finished 

Performing The Finite Element Analysis 
Now the analysis is ready to run: 

           Step 1 In the file menu, click on Run Analysis... to display the Run Analysis 
dialogue box. 

           Step 2 Click on the Batch File option. 

           Step 3 Either enter the path to the batch file you just created manually, or locate it using 
the Browse utility. 

           Step 4 Click on Run Analysis Now.  This will prompt you to save the current Project 
and then close down the Pre-Processor and run the Analysis program. 

           Step 5 You will be task switched from the Analysis Program into a DOS box where the 
analysis will commence.  Equilibrium error percentages are issued for each 
increment as the analysis progresses.  If all of the above stages have been carried 
out successfully, no error should be greater than about 1%. 

           Step 6 Once each analysis is complete, the output is converted into a Microsoft Access 
2.0 database and, once this is finished, you will return to the Analysis dialogue 
box. 
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Figure  4-28:Analysis Docking Module 

           Step 7 Provided both Projects have been run successfully (i.e. without errors- the 
message to the right of the Project name should be OK), highlight the Parent 
Project in the list and click on the Post-Processor button.  This loads the 
Project into the CRISP2D Post-Processor. 

4.4 Post Processing 
In this section you will be introduced to the following features: 

 Displacement Plots 

 Instance Graphs 

 Duration Graphs 

4.4.1 Introduction 
If you entered the Post-Processor directly from running the analysis, the strip footing Project will already 
be loaded.  However you may also enter the Post-Processor by double-clicking on its icon in the 
CRISP2D program group in Windows’ Program Manager.  In this case, you should select Open 
Project... from the File menu and, provided the analysis has been successfully run, you will be able to 
post process the results from your analysis. 

For this example, ensure that you have the Parent Project loaded in the Post-Processor. 
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4.4.2 Displacement Plots 
Displacement plots are drawn directly onto the Graphics Windows.  They provide a representation of how 
the mesh has deformed at any stage in the analysis.  You can view either vector displacements or the 
deformed mesh at any specified magnification. 

           Step 1 Select Displacement Plots... from the Plots  menu.  This displays the 
Displacement Plot dialogue box. 

 
Figure  4-29:Setting Up A Displaced Plot 

           Step 2 Click on the New button to create your plot and change the title to ‘Final 
deformed mesh’. 

           Step 3 Select the Deformed Mesh option. 

           Step 4 Ensure that Absolute is selected and that the Start increment is 10. 

           Step 5 Enter a Magnification Factor of 10.  The Displacement Plot dialogue box should 
now look similar to Figure  4-29. 

           Step 6 Click on OK to exit, once you have finished.  If you execute a Zoom Window to 
magnify the top quadrant of the mesh, the plot should look similar to Figure 
 3-24. 
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Figure  4-30:Deformed Mesh, Magnified 10 Times 

4.4.3 Instance Graphs 
Instance Graphs allow you to investigate output for selected integration points or nodes at particular 
increments in the analysis. 

In this example the results from the Parent analysis, with 10 increments, and the Child analysis, with 5 
increments, are plotted on the same graph to show that the values are identical.  In both cases data is taken 
from the last increment when all loading has been applied. 

           Step 1 In the Select menu, click on Nodes. 

           Step 2 Select all of the nodes along the top edge of the mesh.  These are the points from 
which the graph will draw its data. 

           Step 3 In the Plots menu, click on Instance Graphs... to display the Instance Graphs 
dialogue box. 
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Figure  4-31:Setting Up An Instance Graph 

           Step 4 Click on the New button to create a new graph whose data is taken from the 
selected nodes.  Change the title to ‘Deformation Beneath Strip Load’. 

           Step 5 Ensure that the Data Set Number is 1 and that Analysis Name shows the 
name of the Parent Project you previously created. 

           Step 6 Click on Absolute and enter a Start value of 10. 

           Step 7 Choose ‘X Co-ordinate’ as X Axis Data and ‘Vertical displacement’ as Y 
Axis Data. 

           Step 8 Click on the Add Data Set button and select Data Set 2. 

           Step 9 Select the Child Project from the Analysis Name list (the Parent and Child 
should be the only two Projects in the list ). 

           Step 10 Select Absolute and enter the Start number as 5.  The Instance Graph 
Dialogue box should look like Figure  4-31. 

           Step 11 Click on OK to exit, once you have finished.  You should see a graph similar to 
that displayed in Figure  4-32. 

           Step 12 The appearance of the graph can be altered in the in the Graph Configuration 
dialogue box.  This is accessed via the Options menu, or by double-clicking on 
the graph itself.  The options used in Figure  4-32 were 6 X axis divisions with 
minima and maxima of 0 and 30 respectively, 10 Y axis divisions with minima 
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and maxima of -.1 and 0.1  The legend, axis labels and graph title can also be 
changed in this dialogue box. 

           Step 13 The resulting graph confirms that in this case varying the number of increments 
does not alter the result. 
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Figure  4-32:Comparison Of Vertical Deformations 

4.4.4 Duration Graphs 
Duration graphs allow you to investigate the variation of output from individual integration points or 
nodes over the course of a specified range of increments. 

Up to 10 data sets (each one representing a different integration point or node) can be viewed on the same 
graph.  For this example, two integration points beneath the footing will be used. 

           Step 1 To reactivate the Graphics Window, click on Cascade, Tile Horizontally or 
on Tile Vertically in the Window menu.  These options allow you to switch 
between the Graphics Window and any graphs that are on display. 

           Step 2 In the Select menu, click on Integration Points and then on Clear 
Selection.  Select the integration points at the centroids of the left-most two 
finite elements directly beneath the strip footing. 

           Step 3 In the Plots menu, click on Duration Graphs... to display the Duration Graphs 
dialogue box. 
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Figure  4-33:Setting Up A Duration Graph 

           Step 4 Click on the New button to create your graph and change the title to ‘Vertical 
Strain Paths’. 

           Step 5 Ensure that the Increment Range starts at 1 and finishes at 10. 

           Step 6 Select ‘Increment No.’ as X Axis data and ‘Vertical strain’ as Y Axis data.  The 
Duration Graph dialogue box should now look like Figure  4-33. 

           Step 7 Click on OK to exit, once you have finished.  The graph displayed should look 
similar to Figure  4-34.  You can configure the way the graph looks (axis labels, 
titles and legend) by double-clicking on the graph window and changing the 
set-up in the Graph Configuration dialogue box. 
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Figure  4-34:Graph Showing Strain Paths for Two Integration Points 

4.5 Summary 
By the end of this example you will have made use of the following features: 

 Autosave 

 Units 

 The background grid 

 The Structured Mesh Generator 

 The In Situ Stress converter 

 Parent/Child analyses 

 Instance graphs 

 Duration graphs 

 Displacement plots 

 

4.6 Things To Try Next 
 The mesh used for this example will not necessarily give you the best results. 

 Try using different edge grading values to create a mesh that has smaller 
elements around the base of the footing and larger elements further away.  The 
mesh shown in Figure  4-35 will give better results than the mesh used in the 
example- see if you can duplicate this mesh: 
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Figure  4-35:Refined Finite Element Mesh Created Using The Structured Mesh Generator 

 Try using the unstructured mesh generator to obtain a smoother transition from 
small to large elements. 

 The mesh in Figure  4-36 was created using a single super element (a mega 
element) with super nodes at the four corners and 4 additional super nodes at (0, 
15) (0, 16.667) (5,20) and (7.5, 20) 

 
Figure  4-36 :Refined Finite Element Mesh Created Using The Unstructured Mesh Generator 
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5 OPEN AND 
BRACED 
EXCAVATION 

 

5.1 Introduction 
The following steps will be covered: 

 Starting The Project 

 Defining Units 

 Creating The Finite Element Mesh 

 Defining A Material Zone 

 Assigning Element Properties 

 Defining In Situ Stress Conditions 

 Defining Increment Blocks 

 Defining Boundary Conditions 

 Defining Loads 

 Scale Factors 

 Running The Analysis 

 Displacement Plots 

 Duration Graphs 

5.2 The Problem 
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Figure  5-1 :Excavation Geometry 

The excavation of a basement has been chosen to illustrate the construction techniques which can be set 
up within CRISP2D.  It uses very simple elastic models to enable the construction methods to be modelled 
without too much complexity. 

One of CRISP’s main uses over the years has been to analyse earth excavation and earth retaining 
structures. There are numerous papers included in the Publications Directory which detail analyses which 
model these types of problems.  

This example is a very simple representation of how the program can be used to set up braced and 
unbraced retaining wall problems.  It first analyses an unbraced excavation similar to the example 
problem described in Britto and Gunn then returns back to the Pre-Processor to add a propped retaining 
wall to the excavation and compares the results of the two analyses. 

5.3 Pre-Processing 
This section describes all of the stages that must be completed using the Pre-Processor in order to run the 
finite element analysis.  It is recommended that you save the Project regularly (by clicking on Save 
Project in the File menu). 

5.3.1 Starting The Project 
This section describes the basic processes that should be completed in advance of creating your mesh.  
The steps you will follow include: 

 Selecting A Mesh Mode 

 Entering Project Set-Up Information 

 Entering QA Information 

 Verifying The Base Units System 
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The following procedure describes the actions required to start and set-up a new Project. 

           Step 1 On opening the CRISP2D Pre-Processor, select New Project... from the File 
menu.  This displays the Mesh Mode dialogue box: 

 
Figure  5-2 :Mesh Mode dialogue box 

           Step 2 Click on the Structured Super Mesh button.  This exits the Mesh Mode 
dialogue box, sets you up in Structured Super Mesh mode and opens the Project 
Setup dialogue box. 

 
Figure  5-3:Project Setup Box 

           Step 3 In the Domain Type section, click on the Plane Strain (default) option button 
and click on All Other Elements in the Element Type section. 

           Step 4 The Project Setup should now look like Figure  5-3, with an in situ gravity level 
of 1G, the Apply in Next Increment and Update After Each Increment 
check boxes unchecked and Use The Standard Program selected. 

Click on the Info... button.  This displays the Project Information dialogue box which allows you to enter 
QA information such as job number, operator name, checker name, etc. 
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Figure  5-4:Project Information Box 

           Step 5 Enter data as appropriate.  The date is automatically entered but may be 
manually altered. 

           Step 6 The Project Information dialogue box should now look similar to Figure  5-4. 

           Step 7 Click on OK to return to the Project Setup dialogue box once you have finished. 

           Step 8 Click on OK in the Project Setup dialogue box. 

Defining Units 
At this early stage it is useful to ensure that the correct system of base units is being used. 

           Step 1 In the Options menu, click on Units... to display the Units dialogue box. 

 
Figure  5-5:Units dialogue box 

           Step 2 Use the list boxes to select the appropriate units for Distance, Force, Time and 
Angle as shown in Figure  5-5.  Click on OK to exit, once you have finished. 
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5.3.2 Saving a Project 
It is best to save the project at regular intervals throughout the preparation period. 

           Step 1 In the file menu click on Save Project... 

           Step 2 Select the required directory and enter a filename (with the .scd extension). 

           Step 3 Click on OK to save the project. 

The project name will now appear on the banner at the top of the Pre-Processor. 

Tip Once a project has a filename, you can save the project quickly by using 
the Save Button on the toolbar (the button has a picture of a disk on it).   

 If you set the Autosave feature (select Default Settings in the Options 
menu), you will be able to restore the current file after any unofficial shut 
down of your system. 

5.3.3 Creating A Mesh Using The Structured Mesh 
Generator 

The Structured Super Mesh provides a method of generating large numbers of finite elements from a few 
Super Elements.  For this example, the Super Mesh is used to automatically generate all the soil elements, 
with the wall elements created manually later. 

This section covers all of the stages you must have completed in order to automatically generate the finite 
element mesh.  The steps you will follow include: 

 

 Creating A Super Mesh 

 Defining Edge Gradings 

 Defining Material Zones 

 Assigning Element Properties 

 Generating The Finite Element Mesh 

5.3.4 Creating The Super Mesh 
The easiest way of creating nodes at precise co-ordinates is to create them manually in the Super Node 
List dialogue box. 

           Step 1 In the Mesh menu, click on Super Node List... to display the Super Node List 
dialogue box. 
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Figure  5-6:Super Node List dialogue box 

           Step 2 Enter the following nodes into the Super Node List box, using the TAB key to 
move between the X and Y co-ordinate columns.  Each time you enter a Y co-
ordinate for the last node in the list, press TAB to create a new node and move 
into it’s X co-ordinate column. 

           Step 3 Once all the node co-ordinates have been entered click OK. 

Node X Co-ordinate Y Co-ordinate 

1 10 0 

2 40 0 

3 10 10 

4 40 10 

5 0 0 

6 0 10 

 

           Step 4 In the View menu, click on Zoom and then on Full Page.  The Graphics 
Window will resize to display the nodes at optimum scale. 

           Step 5 To aid you with the creation of the Super Elements it will be best to turn the 
node numbers on.  In the View menu, click on Super Node Numbers 

           Step 6 In the Mesh menu, click on Create Super Elements.  The fact that you can 
now create elements is confirmed by the mode indicator in the status bar, at the 
bottom of the screen. 

           Step 7 Join the nodes together to form the Super Mesh depicted in Figure  5-7. 

           Step 8 To create each Super Elements, you must click on each of its vertex nodes in 
turn, and then click again on the first node to complete the element.  The 
complete sequence of nodes to join together is ; 1 - 2 - 4 - 3 - 1 (first super 
element created) 5 - 1 - 3 - 6 - 5 (second Super Element created) 
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Tip If you make a mistake, you can backtrack one node at a time through the 
elements you have created simply by clicking again on each node. 

           Step 9 When you have finished, you should have two four sided Super Elements in a 
mesh identical to that shown in Figure  5-7. 

           Step 10 In the Edit menu, click on Commit Super Element Creation. This fixes the 
elements, confirming that they are correctly created.  The elements will change 
colour when they committed.  If you are not up to speed with creating elements, 
it is a good idea to Commit elements that have been correctly created as soon as 
each is finished.  This way, if you make a mistake you can use the Abort 
Super Element Creation feature to undo all changes made since Commit 
Super Element Creation was last clicked on. 

 
Figure  5-7:Structured Super Mesh 

Defining Edge Gradings 
Edge Gradings define how the Super Elements will be divided up into finite elements by the mesh 
generator.  In general, better results will be obtained by using smaller finite elements in the parts of the 
mesh that experience the most rapid and/or the largest changes in stress, during the course of the analysis. 

The following procedure defines gradings for the entire Super Mesh. 

           Step 1 In the Select menu, click on Super Edges.  Select the top left-hand horizontal 
edge. 

           Step 2 In the Mesh  menu, click on Super Edge Grading... to display the Super 
Edge Gradings dialogue box. 
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Figure  5-8:Defining Super Edge Gradings 

           Step 3 Enter a value of ‘10’ into the Number of Divisions text box and click on the 
Equal Spacing option.  Weighting values will be automatically entered into 
the list and the dialogue box should now look like Figure  5-8. 

           Step 4 Click on OK to exit, once you have finished. 

           Step 5 Opposite edges of each element are always graded in identical proportions, so by 
defining edge gradings for this edge, gradings have also been automatically 
defined for an additional edge.  Grading markers are shown on the Graphics 
Window as diamond shape boxes positioned on graded super edges.  The mesh 
should now look similar to Figure  5-9. 
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Figure  5-9:Super Edge Gradings 

           Step 6 In the Select menu, click on Clear Selection, or click again on the selected 
edges to de-select them.  You can also use the short-cut key, CTRL+L, to clear the 
selection. 

           Step 7 Select the left-hand vertical edge. 

           Step 8 In the Mesh menu, click on Super Edge Grading... to display the Super Edge 
Grading dialogue box. 
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Figure  5-10:Defining Super Edge Gradings 

           Step 9 Type ‘7’ in the Number of Divisions text box and click on Equal Spacing.  
To add an extra grading at 9m enter the X and Y co-ordinate as in Figure  5-10 
and click Add.  This will show the co-ordinate in the list box.  Click Convert 
and then OK to assign these grading to the selected edge. 

           Step 10 Select Clear from the Select menu. 

           Step 11 Select the top right edge and assign 6 divisions with a factor of 3 and End 1 is 
k times End 2. 

           Step 12 Your supermesh should now appear the same as Figure  5-11. 

Worked Examples 89 



 Pre-Processing 

 
Figure  5-11:Super Edge Grading dialogue box 

5.3.5 Defining Material Zones 
A Material Zone contains information about the soil model and associated soil parameters that are being 
used to model particular regions of the mesh. 

It is necessary to define the number of material zones at this point in order to be able to assign elements to 
zones (the next stage). 

Once you have set up a zone, the soil model and parameters may be entered or changed at any time prior 
to the analysis being run. 

           Step 1 Select Material Properties... from the Mesh  menu.  This displays the 
Material Properties dialogue box. 
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Figure  5-12:Material Properties dialogue box 

           Step 2 Enter the name “Elastic Soil” and select ‘Elastic’(default)  from the Soil Models 
list box.  Material zones are referenced by name elsewhere in the Project so it is 
good practice to give each zone a meaningful title here. 

           Step 3 Enter the following material property values: 

 
Property Value Units 

Eh 3.0E3 kN/m2 

Ev 3.0E3 kN/m2 

νhh 0.25 None 

νvh 0.25 None 

Ghv 1.2E3 kN/m2 

Kw/ γw 0 kN/m3 

γ bulk 20 kN/m3 

 
           Step 4 The Material Properties dialogue box should now look similar to Figure  5-12. 

           Step 5 Click on OK to exit, once you have finished. 

Tip Although values for the soil properties have been defined here, it is 
possible delay defining them right up until just before you run the analysis. 
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5.3.6 Assigning Element Properties 
Every element in the mesh has two properties associated with it:  

 Finite element type, and 

 Material zone 

These properties are assigned to Super Elements in the following manner: 

           Step 1 In the Select menu, click on Domain Super Elements and select both the 
Super Elements. 

           Step 2 In the Mesh menu, click on Element Properties... to display the Element 
Properties dialogue box. 

 
Figure  5-13:Assigning Element types and Material Zones 

           Step 3 Select the Linear Strain Quadrilateral (non consolidating) option. 

           Step 4 Select ‘Elastic Soil’ from the Material Types list box. 

           Step 5 The Element Properties dialogue box should now look like Figure  5-13.  

           Step 6 Click on OK to exit, once you have finished. 

           Step 7 This concludes the definition of element properties. 

5.3.7 Generating The Finite Element Mesh 
You are now at a stage where you can generate the finite element mesh from your super mesh. 

           Step 1 In the Mesh menu, click on Generate Finite Element Mesh.  This will first 
check that you have correctly graded every edge and that you have assigned a 
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generated finite element type to each Super Element.  It will then spend a short 
time performing the automatic generation of the finite element mesh. 

           Step 2 Provided you have completed the above stages correctly, the finite element mesh 
will be displayed as shown in Figure  5-14 and the main menu will change to 
allow you access to the additional options available in Finite Element mesh 
mode. 

 
Figure  5-14:Automatically Generated Finite Element Mesh 

5.3.8 Defining In Situ Stresses 
In situ conditions are defined in terms of stresses at different elevations within the mesh. 

           Step 1 In the Increment menu, click on Define In Situ Stress Conditions... to 
display the In Situ Stress Setup dialogue box. 
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Figure  5-15:In Situ Stress Setup dialogue box 

           Step 2 The top and bottom co-ordinates of the mesh will automatically be entered for 
you. 

           Step 3 Enter the values as shown in Figure  5-15.  Click on OK to exit, once you have 
entered and double-checked the values. 

5.3.9 Defining Increment Blocks 
Increments are the units by which the finite element program advances the analysis.  In each increment, 
the effect of applied load and boundary conditions is calculated and the accumulated strains and pore 
water pressures are updated.  Increments are grouped together in blocks which then model particular 
events in the analysis. 

The first analysis in this example requires only 1 increment block, consists of five increments and allows 
the excavation to be carried out without any structural support. 

           Step 1 In the Increment menu, click on Define Increment Block Parameters... to 
display the Increment Block Information dialogue box. 

 
Figure  5-16 :Defining Increment Blocks 
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           Step 2 Change the name of the first increment block from “Increment Block (untitled)” 
to “Excavate” by entering this into the Description of block text box.  Change 
the number of increments to 5. 

           Step 3 The Increment Block Information dialogue box should now look like Figure 
 5-16.  

           Step 4 Click on OK to exit. 

5.3.10 Setting Up The Construction Sequence 
The construction of the excavation is modelled in a single stage. 

The following procedure describes how to remove elements from the mesh in order to simulate this 
construction sequence. 

           Step 1 Select ‘Excavate’ from the increment block list box on the main toolbar. 

           Step 2 In the Select menu, click on Domain Elements and select all of the elements 
highlighted in Figure  5-17. 

           Step 3 In the Increment menu, click on Remove Elements.  This removes the 
elements from the current, and all subsequent increment blocks. 

 
Figure  5-17:Removing Elements in “Excavate” Increment 

5.3.11 Defining Boundary Conditions 
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Boundary conditions describe to the finite element analysis the ways in which the mesh is physically 
restrained from moving.  This is achieved by applying fixities to edges and nodes in the mesh. 

Once defined, fixities apply in all successive increment blocks.  The Fixities dialogue box and the 
Graphics Window (if View Fixities is toggled on) will only display any fixity that is applied during the 
current increment block. 

Only in situ fixities are applied in this example. 

Defining In Situ Fixities 
In this example the left and right-hand edges are restrained horizontally, and the base is restrained both 
horizontally and vertically during in situ stage.  The following procedure defines fixities for the in situ 
stage: 

           Step 1 Select ‘In situ’ from the Increment Block list box on the main toolbar. 

           Step 2 In the Select menu, click on Edges. 

           Step 3 Select all the far-left-hand and far-right-hand (vertical) edges of the mesh by 
clicking on them. 

           Step 4 In the Increment menu, click on Fixities... to display the Edge Fixity (Group) 
dialogue box. 

 
Figure  5-18:Defining Edge Fixities 

           Step 5 Click on the X Displacement option. 

           Step 6 Specify ‘0’ X direction fixities in the Start Node and Finish Node text 
boxes.  Set the Mid Value to zero either by entering it directly, or by clicking 
on the Interpolate button. 

           Step 7 The Edge Fixity dialogue box should now look like Figure  5-18.  Click on OK 
to exit, once you have finished. 

           Step 8 In the Select menu, click on Clear Selection to ensure that no edges remain 
selected.  Select the bottom (horizontal) edges of the mesh by clicking on them. 
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           Step 9 In the Increment menu, click on Fixities... and define zero X displacement 
fixities as before. 

           Step 10 Click on the Y Displacement option. 

           Step 11 Specify Y direction fixities of zero in the Start Node and Finish Node and 
Mid Value text boxes. 

           Step 12 Click on OK to exit, once you have finished. 

           Step 13 The Graphics Window should now look similar to Figure.  The size of the fixity 
icons can be changed in the Default Settings dialogue box (accessed via the 
Options menu). 

 
Figure  5-19:Fully Defined In Situ Fixities 

5.3.12 Running The Analysis 
The Project should now be saved.  Provided you have followed all of the steps described above, 
preparation of the Project using the Pre-Processor is complete and the analysis is ready to be run, as 
described below. 

           Step 1 In the File menu, click on Run Analysis... to display the Run Analysis 
dialogue box. 
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Figure  5-20:Run Analysis dialogue box 

           Step 2 Click on the Create CRISP Files Now button.  Provided you have followed 
all of the above steps correctly, this will create .GPR and .MPD files for your 
Project.  A message box will appear after each stage has been completed. 

           Step 3 Click on the Run Analysis button.  This will prompt you to save your Project 
and will then run the finite element analysis. 

           Step 4 You will be task switched into a DOS box where the analysis will commence.  
Equilibrium error messages are issued for each increment of the analysis.  

Warning If the error ever exceeds about 1% then this is an indication that something 
is wrong with the input data.  You should quit the analysis immediately 
(by pressing CTRL-BREAK) and double check all data in the Project in the 
Pre-Processor. 

 If there is a problem, first check the in situ stress conditions, then check 
the material properties.  Check also that fixities are correctly defined and 
that the Project Setup is correct. 

           Step 5 Once the analysis is complete, the output is converted into a Microsoft Access 
2.0 database.  Once this is complete, you will see the Analysis Docker dialogue 
box: 
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Figure  5-21:The Analysis Docking Module 

           Step 6 If the Project ran successfully (without errors- the message to the right of the 
Project name should say ‘OK’), click on the Post-Processor button to load 
the Project into the CRISP2D Post-Processor. 

5.4 Post-Processing 
In this section you will be introduced to the following features: 

 Displacement Plots 

 Instance Graphs 

5.4.1 Introduction 
If you entered the Post-Processor directly from running the analysis, the excavation Project will already be 
loaded.  However you may also enter the Post-Processor by double-clicking on its icon in the CRISP2D 
program group in Windows’ Program Manager.  In this case, you should select Open Project... from the 
File menu and, provided the analysis has been successfully run, you will be able to post process the results 
from your analysis. 

Initially this example will look at the deflected shape of the excavation surface and the excavation side 
before returning to the pre processor to make modifications to the analysis.  The deformed shape of the 
excavation will be shown using an displacement plot and two instance graphs. 

5.4.2 Displacement Plots 
Displacement plots are drawn directly onto the Graphics Windows.  They provide a representation of how 
the mesh has deformed at any stage in the analysis.  You can view either vector displacements or the 
deformed mesh at any specified magnification. 

The displacement plot described below illustrates the final shape of the mesh at the end of the last analysis 
increment. 

           Step 1 Select Displacement Plots... from the Plots  menu.  This displays the 
Displacement Plot dialogue box. 
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Figure  5-22:Setting Up A Displaced Mesh Plot 

           Step 2 Click on the New button to create your plot and change the title to “Final 
deformed mesh”. 

           Step 3 Select the Deformed Mesh option. 

           Step 4 Ensure that Absolute is selected and enter a Start increment of  5. 

           Step 5 Set a Magnification Factor of 5.  The Displacement Plot dialogue box should 
now look similar to Figure  5-22. 

           Step 6 Click on OK to exit, once you have finished.  Figure  5-23 shows the displaced 
mesh plot in Graphics Window (a zoom window has been executed to show 
more clearly the excavated region). 
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Figure  5-23:Deformed Mesh at Collapse 

Tip Displacement plot look clearer if you select good line styles and colours. 
To change the line styles, Select Line Styles... from the Options menu. To 
change the line colours, select Colour... from the Options menu. 

5.4.3 Instance Graphs 
 

Instance Graphs allow you to investigate output for selected integration points or nodes at particular 
increments in the analysis. 

The graph described below shows the deformation of the base of the excavation at the end of the analysis 

           Step 1 In the Plots menu, click on Clear Current Plot.  This makes it easier to see 
which nodes you are selecting. 

           Step 2 Select ‘Excavate’ from the Increment Block list box on the main toolbar - this 
will make the selection of nodes clearer. 

           Step 3 In the Select menu, click on Nodes. 

           Step 4 Select all of the nodes along the excavated surface from left to right. 

           Step 5 In the Plots menu, click on Instance Graphs... to display the Instance Graphs 
dialogue box. 

 
Figure  5-24:Setting Up An Instance Graph 

           Step 6 Click on the New button to create a new graph whose data is taken from the 
selected nodes.  Change the title to “Excavated Surface Heave”. 
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           Step 7 Click on Absolute and enter a Start value of 5. 

           Step 8 Choose ‘X Co-ordinate’ as X Axis Data and ‘Vertical displacement’ as Y 
Axis Data. 

           Step 9 Click on OK to exit, once you have finished.  You should see a graph similar to 
that displayed in Figure  5-25. 

The appearance of the graph can be altered in the in the Graph Configuration dialogue box.  This is 
accessed by double-clicking on the graph itself. 

 
Figure  5-25:Heave of basement surface after excavation 

 

The graph described below shows the deformation of the side of the excavation at the end of the analysis. 

           Step 10 In the Select menu, click on Clear Select. 

           Step 11 Select all of the nodes down the excavated surface from top to bottom. 

           Step 12 In the Plots menu, click on Instance Graphs... to display the Instance Graphs 
dialogue box. 
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Figure  5-26:Setting Up An Instance Graph 

           Step 13 Click on the New button to create a new graph whose data is taken from the 
selected nodes.  Change the title to “Excavated Side Movement”. 

           Step 14 Click on Absolute and enter a Start value of 5. 

           Step 15 Choose ‘Horizontal displacement’ as X Axis Data and ‘Y Co-ordinate’ as Y 
Axis Data. 

           Step 16 Click on OK to exit, once you have finished.  You should see a graph similar to 
that displayed in Figure  5-27. 

The appearance of the graph can be altered in the in the Graph Configuration dialogue box.  This is 
accessed by double-clicking on the graph itself. 
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Figure  5-27:Horizontal  Displacements of excavation side. 

On first inspection this graph may appear to have an unexpected profile but on  closer inspection of the 
horizontal stresses (Select the integration points down the back of the wall and plot an instance graph as in 
Figure  5-28) the reasons for the apparent pinning of the top of the excavation can be seen.  As the sides of 
the excavation move the horizontal stress down the side of the wall decreases proportionally with the 
height from the top of the excavation, however the material model is Elastic and so does not experience 
any yielding.  A much better result would be attained from either an elastic, stiffness varying with depth, 
model or an elastic perfectly plastic model. 

As discussed at the beginning, this example has been made a simple as possible, but still shows the 
important of understanding the results.  Under normal circumstances this analysis should be re-done with 
a yielding soil model, however, this example will continue with the basic model. 
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 Pre-Processor - (Adding a retaining wall) 

 
Figure  5-28:Comparison Of Horizontal Stresses during analysis 

5.4.4 Saving the Project 
The example will now lead you through some alterations to the pre processing of the file.  Before we do 
this you should save the project. Select Save Project from the File menu. Select Exit from the File 
menu to leave the Post-Processor. 

 

5.5 Pre-Processor - (Adding a retaining wall) 

5.5.1 Opening a project 
In the File menu, click on Open File and select the scd file from the appropriate directory.  The example 
will then be displayed on the graphics screen. 

5.5.2 Defining a new Material Zone 
           Step 1 Select Material Properties... from the Mesh  menu.  This displays the 

Material Properties dialogue box. 
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Figure  5-29:Material Properties dialogue box 

           Step 2 Click on the New button and enter the name “Concrete Wall” and select 
‘Elastic’(default)  from the Soil Models list box.  Material zones are referenced 
by name elsewhere in the Project so it is good practice to give each zone a 
meaningful title here. 

           Step 3 Enter the following material property values: 

 
Property Value Units 

Eh 1.0E5 None 

Ev 1.0E5 None 

νhh 0.30 None 

νvh 0.30 None 

Ghv 31250 kN/m2 

Kw/ γw 0 kN/m3 

γ bulk 20 kN/m3 

 
           Step 4 The Material Properties dialogue box should now look similar to Figure  5-29. 

           Step 5 Click on OK to exit, once you have finished. 

Tip Although values for the soil properties have been defined here, it is 
possible delay defining them right up until just before you run the analysis. 

5.5.3 Swapping elements. 
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To simulate the construction of a retaining wall we need to swap a column of soil elements in the mesh for 
a column of wall elements.  CRISP2D does not allow you to change the material properties of elements 
without using a Stop - Re start analysis.  It is possible however to define Super Imposed Elements. 

Super-imposed elements are two “Layers” of elements that overlap.  As overlapping elements are not 
permitted in CRISP2D, it is necessary to remove the old elements, in this example, the soil, and replace 
them with the new elements, in this example, the Wall. 

The first process in this sequence is to define a super-imposed set of elements 

Defining Super Imposed elements 
           Step 1 In the Select menu, click on Elements. Select the elements down the side of 

the excavation, to include all but the bottom two elements in the strip (see Figure 
 5-30). 

 
Figure  5-30:Defining Super Imposed elements 

           Step 2 In the Mesh menu, click on Super-Impose Elements... to display the 
Super-Impose Elements dialogue box. 

           Step 3 Give the layer the name of “Wall”, select “Concrete Wall” from the Material 
Name list and Non Consolidation for the Finite Element Type. 

           Step 4 Click OK 
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Figure  5-31:Super Impose Elements dialogue box: 

 

This process will create a set of elements with the same geometry as the selected set and will have placed 
them on top of the existing element set. 

As the wall is not in the analysis at the in situ stage, it must be removed. 

Creating a “Swap” Increment 
An increment in which elements are swapped is no different to any other increment, it is simply an 
increment where elements are added at the same location as elements which have just been removed. 

The first step is to create the Increment Block. 

           Step 1 In the Increment menu, click on Define Increment Block Parameters... to 
display the Increment Block Information dialogue box. 

           Step 2 Highlight Excavate increment that was created earlier and click on Insert.  This 
will add an increment before the Excavate increment. 

           Step 3 Change the name of the inserted increment block from “Increment Block 
(untitled)” to “Install Wall” by entering this into the Description of block text 
box.  Change the number of increments to 2. 

           Step 4 The Increment Block Information dialogue box should now look like Figure 
 5-32. 

           Step 5 Click on OK to exit. 
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Figure  5-32 :Defining Increment Blocks 

Adding and Removing Elements 
The final stage or this operation is to remove the wall in the in situ stage, remove the soil and add the wall 
at the “Install Wall” stage. 

When you click on a point which two elements occupy the multi-selection box will appear as shown in 
Figure  5-33.  Use the material property of the elements, shown in the multi select box, to distinguish 
between the elements. 

 
Figure  5-33:Multi-selection dialogue box 

           Step 1 Make sure that the in situ increment is chosen from the Increment box. 

           Step 2 In the Select menu, click on Clear Selection to clear the current element 
selection. 
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           Step 3 Select the Wall Elements. 

           Step 4 In the Increment menu, click on Remove Elements to remove the wall 
elements from the in situ stage. 

           Step 5 Select “Install Wall” from the Increment Box. 

           Step 6 In the Select menu, click on Clear Selection to clear the current element 
selection. 

           Step 7 Select the soil elements which are to be replaced by the wall elements. 

           Step 8 In the Increment menu, click on Remove Elements to remove the soil 
elements from the “Install Wall” stage. 

           Step 9 Click on the Removed Elements icon on the toolbar to view the elements 
currently removed at the “Install Wall” stage.  Both the wall and soil elements 
should be present in the screen view. 

           Step 10 In the Select menu, click on Clear Selection to clear the current element 
selection. 

           Step 11 Select the Wall Elements 

           Step 12 In the Increment menu, click on Add Elements to add the wall elements at the 
“Install Wall” stage. 

This example has been made particularly simple to show the principles of the program.  It does not reflect 
a standard that professional analyses should be conducted to. For more information on installation effects 
and retaining walls refer to the Publications Directory. 

Before running the analysis chose Save As.. from the File menu and save the project under a different 
name but with the same .scd extension.  This will stop the data from the original .scd file being 
overwritten. 

5.5.4 Running The Analysis 
The Project should now be saved.  Provided you have followed all of the steps described above, 
preparation of the Project using the Pre-Processor is complete and the analysis is ready to be run, as 
described below. 

           Step 1 In the File menu, click on Run Analysis... to display the Run Analysis 
dialogue box. 

 

Worked Examples 110 



 Pre-Processor - (Adding a retaining wall) 

 

Figure  5-34:Run Analysis dialogue box 

           Step 2 Click on the Create CRISP Files Now button.  Provided you have followed 
all of the above steps correctly, this will create .GPR and .MPD files for your 
Project.  A message box will appear after each stage has been completed. 

           Step 3 Click on the Run Analysis button.  This will prompt you to save your Project 
and will then run the finite element analysis. 

           Step 4 You will be task switched into a DOS box where the analysis will commence.  
Equilibrium error messages are issued for each increment of the analysis.  

Warning If the error ever exceeds about 1% then this is an indication that something 
is wrong with the input data.  You should quit the analysis immediately 
(by pressing CTRL-BREAK) and double check all data in the Project in the 
Pre-Processor. 

 If there is a problem, first check the in situ stress conditions, then check 
the material properties.  Check also that fixities are correctly defined and 
that the Project Setup is correct. 

           Step 5 Once the analysis is complete, the output is converted into a Microsoft Access 
2.0 database.  Once this is complete, you will see the Analysis Docker dialogue 
box: 
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Figure  5-35:The Analysis Docking Module 

If the Project ran successfully (without errors- the message to the right of the Project name should say 
‘OK’), click on the Post-Processor button to load the post processor. 

5.6 Post-Processor 
The post processor options for the two .scd files (one with and one without the wall) are the same.  To 
produce the deformation plot and the two instance graphs - refer back to the previous post processor 
description earlier in the example.  

Remember that the last increment is now 7 and not 5 when plotting the results. 

Compare your results to the ones below. 

 
Figure  5-36:Displacement Plot with Wall 
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Figure  5-37:Basement Heave 

 

 
Figure  5-38:Wall deflection 

5.7 Summary 
By the end of this example you will have made use of the following features: 

 Autosave 

 Units 

 The Structured Mesh Generator 
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 Creating finite elements manually 

 Construction sequences 

 Super imposing elements 

 Removal of in situ elements 

 Displacement plots 

 Instance graphs 

5.8 Things To Try Next 
 Try applying a horizontal fixity to the second node down the wall, during the 

excavation stage.  This will model a perfectly stiff prop. 

 Applying a Beam or Bar element to the wall to model the prop forces in the wall. 



 Introduction 

6 CENTRIFUGE TEST 
OF AN 
EMBANKMENT 

 

6.1 Introduction 
This example is taken from the paper “Numerical modelling of a centrifuged embankment on soft clay”, 
by Almeida, Britto and Parry (see the Publications Directory).  It is designed to introduce you to a 
centrifuge type analysis, with coupled-consolidation (Biot) drainage conditions, using the Modified Cam 
clay soil model and combining automatic mesh generation with manual, finite element creation.  The 
mesh used is almost identical to the mesh described in the paper, with some slight modifications to 
simplify the mesh creation process.  Results from the analysis are then compared with observed results, 
obtained from an experimental centrifuge analysis on a prototype model of the embankment. 

The subject of the example is the modelling of a sand embankment constructed on soft clay. 

The following steps will be covered: 

 Starting The Project 

 Defining Units 

 Creating The Finite Element Mesh 

 Defining A Material Zone 

 Assigning Element Properties 

 Defining In Situ Stress Conditions 

 Defining Increment Blocks 

 Defining Boundary Conditions 

 Defining Loads 

 Scale Factors 

 Running The Analysis 

 Displacement Plots 

 Duration Graphs 
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6.2 The Problem 
The analysis simulates the construction of a sand embankment on an overconsolidated clay crust 
overlying a normally consolidated clay layer.  The embankment is constructed in five stages.  After each 
of the first three stages, time is allowed for the equalisation of pore pressures to occur.  The final two 
layers are then constructed relatively quickly in order to induce failure. 

6.3 Pre-Processing 
This section describes all of the stages that must be completed using the Pre-Processor in order to run the 
finite element analysis.  It is recommended that you save the Project regularly (by clicking on Save 
Project in the File  menu). 

6.3.1 Starting The Project 
This section describes the basic processes that should be completed in advance of creating your mesh.  
The steps you will follow include: 

 Selecting a mesh mode 

 Entering Project set-up information 

 Entering QA information 

 Verifying the base units system 

The following procedure describes the actions required to start and set-up a new Project. 

           Step 1 On opening the CRISP2D Pre-Processor, select New Project... from the File  
menu.  This displays the Mesh Mode dialogue box: 

 

Figure  6-1:Mesh Mode dialogue box 

           Step 2 Click on the Structured Super Mesh button.  This exits the Mesh Mode 
dialogue box, sets you up in Structured Super Mesh mode and opens the Project 
Setup dialogue box. 

Worked Examples 116 



 Pre-Processing 

 
Figure  6-2:Project Setup dialogue box 

           Step 3 In the Domain Type section, click on the Plane Strain option button and click 
on All Other Elements in the Element Type section. 

           Step 4 The Project Setup should now look like Figure  4-3, with an in situ gravity level 
of 1G, the Apply in Next Increment and Update After Each Increment 
check boxes unchecked and Use The Standard Program selected. 

           Step 5 Click on the Info... button.  This displays the Project Information dialogue box 
which allows you to enter QA information such as job number, operator name, 
checker name, etc. 

 
Figure  6-3:Project Information dialogue box 
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           Step 6 Enter data as appropriate.  The date is automatically entered but may be 
manually altered. 

           Step 7 The Project Information dialogue box should now look similar to Figure  6-3.  
Click on OK to return to the Project Setup dialogue box, once you have finished. 

           Step 8 Click on OK to exit. 

Defining Units 
At this early stage it is useful to ensure that the correct system of base units is being used. 

           Step 1 In the Options menu, click on Units... to display the Units dialogue box. 

 

Figure  6-4:Units dialogue box 

           Step 2 Use the list boxes to select the appropriate units for Distance, Force, Time and 
Angle as shown in Click on OK to exit, once you have finished. 

6.3.2 Creating A Mesh Using The Structured Mesh 
Generator 

The Structured Super Mesh mode provides a method of generating large numbers of finite elements from 
a few super elements.  For this example, the super mesh is used to automatically generate the lower 
portion of the mesh (comprising the two clay layers), with the remainder (the sand embankment) created 
manually. 

This section covers all of the stages you must have completed in order to automatically generate the finite 
element mesh.  The steps you will follow include: 

 Creating a super mesh 

 Defining edge gradings 

 Defining material zones 

 Assigning element properties 
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 Generating the finite element mesh 

6.3.3 Creating The Super Mesh 
Nodal co-ordinates for the super mesh are taken straight out of the paper to which this example is 
attributed.  The easiest way of creating nodes at these precise co-ordinates is to create them manually in 
the Super Node List dialogue box. 

           Step 1 In the Mesh menu, click on Super Node List... to display the Super Node List 
dialogue box. 

 
Figure  6-5:Super Node List dialogue box 

           Step 2 Enter the following nodes into the Node List box, using the TAB key to move 
between the X and Y co-ordinate columns.  Each time you enter a Y co-ordinate 
for the last node in the list, press TAB to create a new node and move into its X 
co-ordinate column. Once you have entered all the nodes, click on OK to display 
them.  

Node X Co-ordinate Y Co-ordinate 

1 0 0 

2 17.2 0 

3 39 0 

4 67.5 0 

5 0 11.5 

6 17.2 11.5 

7 39 11.5 

8 67.5 11.5 

9 0 15.5 

10 17.2 15.5 

11 39 15.5 
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Node X Co-ordinate Y Co-ordinate 

12 67.5 15.5 

13 0 16.4 

14 17.2 16.4 

15 39 16.4 

16 67.5 16.4 

17 20.8 14.2 

18 35.4 14.2 

19 20.8 15.5 

20 35.4 15.5 

 

           Step 3 In the View menu, click on Zoom and then on Full Page.  The Graphics 
Window will resize to display the nodes at optimum scale. 

           Step 4 In the Mesh menu, click on Create Super Elements.  The fact that you can 
now create elements, is confirmed by the mode indicator in the status bar that 
runs along the bottom of the screen. 

           Step 5 Join the nodes together to form the super mesh depicted in   To create each super 
element, you must click on each of its vertex nodes in turn, and then click again 
on the first node to complete the element.  Remember that you do not ever need 
to press CTRL because you are not creating any new nodes. 

Tip If you make a mistake, you can backtrack one node at a time through the 
elements you have created simply by clicking again on each node. 

           Step 6 When you have finished, you should have eleven four sided super elements in a 
mesh identical to that shown in Figure  6-6. 
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Figure  6-6:Structured Super Mesh 

           Step 7 In the Edit menu, click on Commit Super Element Creation. This fixes the 
elements, confirming that they are correctly created.  The elements will change 
colour when they committed.  If you are not up to speed with creating elements, 
it is a good idea to Commit elements that have been correctly created as soon as 
each is finished.  This way, if you make a mistake you can use the Abort 
Super Element Creation feature to undo all changes made since Commit 
Super Element Creation was last clicked on. 

Defining Edge Gradings 
Edge Gradings define how the super elements will be divided up into finite elements by the mesh 
generator.  In general, better results will be obtained by using smaller finite elements in the parts of the 
mesh that experience the most rapid and/or the largest changes in stress, during the course of the analysis. 

The following procedure defines gradings for the entire super mesh. 

           Step 1 In the Select menu, click on Super Edges.  Select the two leftmost, horizontal, 
edges with a y co-ordinate of 15.5. 

           Step 2 In the Mesh  menu, click on Super Edge Grading... to display the Multiple 
Super Edge Gradings dialogue box. 
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Figure  6-7:Defining Super Edge Gradings 

           Step 3 Enter a value of ‘2’ into the No. Divisions text box and click on the Equal 
Spacing option.  Weighting values will be automatically entered into the list 
and the dialogue box should now look like  

           Step 4 Click on OK to exit, once you have finished. 

           Step 5 Opposite edges of each element are always graded in identical proportions, so by 
defining edge gradings for these two edges, gradings have also been 
automatically defined for six additional edges.  Grading markers are shown on 
the Graphics Window as diamond shape boxes positioned on graded super 
edges.  The mesh should now look similar to Figure  6-8. 
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Figure  6-8:Super Edge Gradings 

           Step 6 In the Select menu, click on Clear Selection, or click again on the selected 
edges to de-select them.  You can also use the short-cut key, CTRL+L, to clear the 
selection. 

           Step 7 Select the top two left-hand vertical edges and the uppermost right-hand vertical 
edge. 

           Step 8 In the Mesh menu, click on Super Edge Grading... to display the Multiple 
Super Edge Grading dialogue box. 
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Figure  6-9:Defining Super Edge Gradings 

           Step 9 Type ‘1’ in the Enter Weighting text box and click on Add.  This will add a 
single grading of 1.0 to the list.  The dialogue box should now look like  

           Step 10 Click on OK to exit. 

           Step 11 Clear the current selection and then select the bottom middle horizontal edge. 

           Step 12 Assign it four equally spaced divisions, as described above (in steps 2 to 4).  The 
dialogue box should look like  when you have finished. 
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Figure  6-10:Super Edge Grading dialogue box 

           Step 13 Clear the selection and then select the bottom left-hand vertical edge and the 
bottom right-hand horizontal edge. 

           Step 14 Assign them three equally spaced divisions, as described above. 

           Step 15 This concludes the definition of edge gradings.  Every edge in the mesh should 
now have gradings assigned to it.  To check this, make sure that each edge in the 
mesh is displayed with at least one grading marker on it, except for those edges 
with just one division.  The final mesh should look similar to  
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Figure  6-11:Fully Assigned Super Edge Gradings 

6.3.4 Defining Material Zones 
A Material Zone contains information about the soil model and associated soil parameters that are being 
used to model particular regions of the mesh. 

It is necessary to define the number of material zones at this point in order to be able to assign elements to 
zones (the next stage). 

Once you have set up a zone, the soil model and parameters may be entered or changed at any time prior 
to the analysis being run. 

           Step 1 Select Material Properties... from the Mesh  menu.  This displays the 
Material Properties dialogue box. 
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Figure  6-12:Material Properties dialogue box 

           Step 2 Enter the name “Kaolin”. Select “Consolidating” from the Soil Condition list 
box and “Modified Cam clay” from the Soil Models list box.  Material zones 
are referenced by name elsewhere in the Project, so it is good practice to give 
each zone a meaningful title here. 

           Step 3 Enter the following material property values: 

 
Property Value Units 

κ  0.05 None 

λ  0.25 None 

ecs 2.44 None 

M 0.9 None 

G  3.2E3 kN/m2 

ν 0 None 

γw  9.81 kN/m3 

γbulk 15.4 kN/m3 

kx 2.0E-9 m/sec 

ky 2.0E-9 m/sec 

 
           Step 4 The Material Properties dialogue box should now look similar to  
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           Step 5 Click on the New button to create a second soil model and enter the name 
“Gault clay”.  Select “Consolidating” soil condition and the “Modified Cam 
Clay” model, then enter the following material property values: 

 
Property Value Units 

κ  0.035 None 

λ  0.219 None 

ecs 1.96 None 

M 1 None 

G 3.5E3 kN/m2 

ν 0 None 

γw  9.81 kN/m3 

γbulk 15.4 kN/m3 

kx 8.64E-5 m/sec 

ky 8.64E-5 m/sec 

 
           Step 6 Click on the New button to create a third soil model and enter the name “Sand”.  

Select the “Elastic” model and enter the following material property values: 

 
Property Value Units 

Eh 3.0E3 kN/m2 

Ev 3.0E3 kN/m2 

vvh 0.3 None 

vhh 0.3 None 

Ghv 937.5 kN/m2 

γw  9.81 kN/m3 

γbulk 16.9 kN/m3 

kx 0 m/sec 

ky 0 m/sec 

 
           Step 7 Click on OK to exit, once you have finished. 

Tip Although values for the soil properties have been defined here, it is 
possible to delay defining them right up until just before you run the 
analysis. 
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6.3.5 Assigning Element Properties 
Every element in the mesh has two properties associated with it:  

 Finite element type, and 

 Material zone 

These properties are assigned to finite elements in the following manner: 

           Step 1 In the Select menu, click on Domain Super Elements and select the bottom 
three super elements by clicking on them. 

           Step 2 In the Mesh menu, click on Element Properties... to display the Element 
Properties dialogue box. 

 
Figure  6-13:Assigning Element types and Material Zones 

           Step 3 Select the Linear Strain Triangle (consolidating) option. 

           Step 4 Select ‘Kaolin’ from the Material Zone list box. 

           Step 5 The Element Properties dialogue box should now look like Figure  6-13.  Click 
on OK to exit, once you have finished. 

           Step 6 In the Select menu, click on Clear Selection.  Select the two narrow elements 
in the top row (one on the left, and one on the right). 

           Step 7 Define the element type as L. S. Quadrilateral (consolidating) and the 
material zone as Gault clay. 

           Step 8 In the Select menu, click on Clear Selection.  Select the remaining elements 
(in a horizontal swathe across the middle of the mesh). 
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           Step 9 Define the element type as Linear Strain Triangle (consolidating) and the 
material zone as Gault clay. 

           Step 10 This concludes the definition of element properties. 

6.3.6 Generating The Finite Element Mesh 
You are now at a stage where you can generate the finite element mesh from your super mesh. 

           Step 1 In the Mesh menu, click on Generate Finite Element Mesh.  This will first 
check that you have correctly graded every edge and that you have assigned a 
generated finite element type to each super element.  It will then spend a short 
time performing the automatic generation of the finite element mesh. 

           Step 2 Provided you have completed the above stages correctly, the finite element mesh 
will be displayed as shown in Figure  6-14 and the main menus will change, to 
allow you access to the additional options available in Finite Element Mesh 
mode. 

 
Figure  6-14:Automatically Generated Finite Element Mesh 
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6.3.7 Defining In Situ Stresses 
In situ conditions are defined in terms of stresses at different elevations within the mesh.  In this example, 
all of the stresses are defined in terms of effective stress.  The effective vertical stresses have been 
calculated directly from the bulk modulus of soil (specified earlier in the defining material zones stage) 
and the bulk modulus of water (taken as 9.81 kN/m3).  The other parameters have been derived from the 
paper. 

           Step 1 In the Increment menu, click on Define In Situ Stress Conditions... to 
display the In Situ Stress Setup dialogue box. 

 
Figure  6-15:In Situ Stress Setup dialogue box 

           Step 2 Select the second row of the in situ stresses grid by clicking on the row number 
(to the left of the Height column).  This enables the Insert button, which you 
should click on four times to create the required number of reference elevations. 

           Step 3 Enter the values as shown in Figure  6-15.  Click on OK to exit, once you have 
entered and double-checked the values. 

6.3.8 Defining Increment Blocks 
Increments are the units by which the finite element program advances the analysis.  In each increment, 
the effect of applied load and boundary conditions is calculated and the accumulated strains and pore 
water pressures are updated.  Increments are grouped together in blocks which then model particular 
events in the analysis. 

This analysis requires eleven increment blocks.  The first block consists of only one increment and allows 
the water table to be defined.  The subsequent ten blocks, of ten increments each, allow the embankment 
to be built in five stages, with a consolidation period after each stage. 

           Step 1 In the Increment menu, click on Define Increment Block Parameters... to 
display the Increment Block Information dialogue box. 

Worked Examples 131 



 Pre-Processing 

 
Figure  6-16 :Defining Increment Blocks 

           Step 2 Change the name of the first increment block from “Increment Block (untitled)” 
to “Define Water Table” by entering this into the Description of Block text 
box. 

           Step 3 Assign a time-step of 100 seconds by entering ‘100’ into the Time-Step for 
Block text box. 

           Step 4 Click on the New button to create a new increment block. 

           Step 5 Change the name to “Add Layer 1”. 

           Step 6 Click on OK to exit. 

           Step 7 In the Options menu, click on Units... and change the units for time from 
seconds to days. 

           Step 8 In the Increment menu, click on Define Increment Block Parameters.... 

           Step 9 Click on ‘Add Layer 1’ in the Increment Block list. 

           Step 10 Enter a time-step of 2 days, and allocate ten increments to the block. 

           Step 11 Define nine more increment blocks with the following properties: 
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Block No. Description No. of Incs Total Time-Step 

3 Layer 1 consolidation 10 250 days 

4 Add Layer 2 10 2 days 

5 Layer 2 consolidation 10 648 days 

6 Add Layer 3 10 2 days 

7 Layer 3 consolidation 10 848 days 

8 Add Layer 4 10 2 days 

9 Layer 4 consolidation 10 28 days 

10 Add Layer 5 10 2 days 

11 Layer 5 consolidation 10 28 days 

 
           Step 12 The Increment Block Information dialogue box should now look like Figure 

 6-16.  Note that the entry for the first time-step has been automatically converted 
into Days.  Click on OK to exit, once you have finished. 

6.3.9 Restricting Output 
This analysis comprises 101 increments in eleven increment blocks.  By default, output is written to disk 
for every integration point of every element, eighty four times (once at in situ stage plus once for each 
increment ).  This volume of output will take up approximately 40 Mb hard disk space.  If you wish to 
limit this demand for space, you can restrict the volume of output written by only requesting it at specified 
increments.  The procedure below describes how to request that output only be written for the last 
increment of each increment block. 

           Step 1 In the Increment menu, click on Specify Output... to display the Output 
Options dialogue box. 
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Figure  6-17:Specifying Restricted Output 

           Step 2 In the Increment Block list, click on ‘Add layer 1’. 

           Step 3 Click on the ‘Output for last increment of block only’ option. 

           Step 4 Click on the Apply Options to all Increment Blocks button. 

           Step 5 The dialogue box should look similar to when you have finished.  Click on OK 
to exit. 

6.3.10 Creating The Embankment 
The positions of some of the nodes in the embankment are defined in the paper by the positions of the 
sand layers in the centrifuge prototype.  The easiest way to create a mesh for the embankment that 
matches the prototype is to specify these nodes directly (using the Node List) and then join the nodes to 
form elements.  This is the same method as was used to build the super mesh. 

The stages you will follow here include: 

 Adding the nodes 

 Saving the Project as a Bookmark 

 Drawing the elements 
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Adding The Nodes 
           Step 1 In the Mesh menu, click on Node List... to display the finite element Node List 

dialogue box.  Add the following nodes to the bottom of the list: 

 
Node No. X co-ordinate Y co-ordinate 

72 46.9 18.2 

73 54.3 19 

74 59.3 18.6 

75 33.7 16.4 

76 46 21.3 

77 51.6 22.1 

78 57.2 21.7 

79 62.8 21.7 

80 67.5 23.2 

81 27.2 16.4 

82 34.9 19.6 

83 45.4 26.4 

84 49.6 26.7 

85 60.7 26.4 

86 67.5 28.2 

87 29.6 16.4 

88 31.6 16.4 

89 37.2 19.9 

90 37.2 18.8 

91 44 23.2 

92 44 22.3 

93 48.4 24.6 

94 48.4 23.8 

95 55.7 23.8 

96 55.7 24.9 

97 61.3 23.8 

98 61.3 24.9 

99 67.5 26.1 

100 67.5 24.9 

101 53.3 26.2 

102 34 20 

103 40 23 

104 22.5 16.4 
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           Step 2 Click OK to exit, once you have finished. 

Making A Bookmark 
It is a good idea to save the Project as a Bookmark before you start drawing the finite elements.  This way, 
if anything goes seriously wrong with the elements that you draw you can easily return to this point 
simply by loading the saved Bookmark. 

           Step 1 Save the Project by clicking on Save Project in the file menu. 

           Step 2 In the Edit menu, click on Save As Bookmark... to display the Save 
Bookmark dialogue box. 

 

Figure  6-18:Saving a Bookmark 

           Step 3 Enter a descriptive save name and any notes you wish to add. 

           Step 4 Click on Save to store the bookmark and exit. 

Drawing The Elements 
Several features may be of use when you come to draw the elements: 

You are informed when each element is complete by its changing colour.  The colour will change again 
when you start creating a new element. 

If you make a mistake, you can undo your changes by backtracking through the newly created elements 
by clicking again on the vertex nodes.   

Remember not to try to start creating a new element from the last node of the element you have just 
completed as this will instead take you back a step. 

If things go severely wrong, you can go back to the mesh as it existed before you began creating elements 
by loading the saved bookmark (click on Load Bookmark... in the Edit menu). 

           Step 5 In the Mesh menu, click on Create Elements. 

           Step 6 Join the nodes together to form triangular and quadrilateral elements as depicted 
in below.   
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Figure  6-19:The Completed Embankment Mesh 

Tip The best way of exactly copying this mesh is to draw the elements layer by 
layer (see Figure  6-21 to Figure 6-27) 

 As soon as you complete each layer, click on Commit in the Edit menu to 
make the changes permanent.  If you make a mistake, you can then undo 
your changes by clicking on Abort Element Creation in the Edit menu.  
This will take you back to the stage you were at when you last clicked on 
Commit. 

6.3.11 Setting Up The Construction Sequence 
The construction of the embankment is modelled in five two-part stages.  During each stage, a layer of 
sand is added over a short period of time.  A longer period of time is then allowed for the excess pore 
pressures, induced by the weight of the additional layer, to dissipate, after which the next layer is added. 

The following procedure describes how to add and remove elements to and from the mesh in order to 
simulate this construction sequence. 

           Step 1 Select ‘In situ’ from the Increment Block list box on the main toolbar. 

           Step 2 In the Select menu, click on Domain Elements and select all of the elements 
above or equal to a Y co-ordinate of 16.4 by clicking on them, as shown in 
Figure  6-20. 
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Figure  6-20:The Elements That Will Form the Embankment 

           Step 3 In the Increment menu, click on Remove Elements.  This removes the 
elements from the current, and all subsequent increment blocks. 

           Step 4 Select ‘Add Layer 1’ from the Increment Block list box on the main toolbar. 

           Step 5 In the View menu, click on Removed Elements .  This displays all elements 
that are not present in the primary mesh. 

           Step 6 In the Select menu, click on Clear Selection and select the elements shown in 
Figure  6-21 by clicking on them. 
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Figure  6-21:Add Layer 1 

           Step 7 In the Increment menu, click on Add Elements.  This adds the elements to the 
current and all subsequent increment blocks, simulating the construction of the 
first layer of the embankment. 

           Step 8 Repeat steps 4 to 7 for each of the ‘Add layer’ increment blocks, selecting the 
elements shown and adding them to the correct increment blocks. 

Remember to select the relevant increment block for each constructed layer from the Increment Block list 
box before you add the elements back into the primary mesh. 
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Figure  6-22:Add Layer 2 
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Figure  6-23:Add Layer 3 
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Figure  6-24:Add Layer 4 
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Figure  6-25:Add Layer 5 

           Step 9 In the View menu, click on Present Elements. 

           Step 10 You should now check that the sequence is correct.  Click on the Increment 
Block list box so that the scrollable list of available increment blocks appears. 

           Step 11 Click once on ‘In situ’ so that the list disappears, leaving the In situ stage 
highlighted. 

           Step 12 Press the Down and Up cursor keys ( ↓ and ↑ ) to view the construction 
sequence as it progresses through the increment blocks.  Ensure that the layers 
are added in the correct blocks. 

           Step 13 This concludes the construction sequence set-up. 

6.3.12 Assigning Element Properties 
All of the newly created finite elements need to be assigned a finite element type and a material zone.  
Elements in the embankment will all be non consolidating triangles or quadrilaterals in the ‘Sand’ material 
zone.  The remaining new elements are consolidating triangles and quadrilaterals in the ‘Gault clay’ 
material zone. 
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           Step 1 Select ‘Add layer 5’ from the Increment Block list box on the main toolbar.  This 
increment block is chosen so that all of the elements in the mesh are present at 
once. 

           Step 2 To make it easier to see how far you have got with defining element properties, 
click on Legend in the View menu then click on Material Zones (also in the 
View menu). 

           Step 3 This displays the three material zones as coloured regions.  The Legend contains 
the key to these colours.   

Tip To change the colours, click on Colour... in the Options menu to display 
the Colour Configuration dialogue box. 

 To change a colour, double click on the coloured square adjacent to the 
material zone or finite element type that you wish to change and select a 
colour from the dialogue box that appears. 

           Step 4 In the Select menu, click on Domain Elements. 

           Step 5 Select all of the triangular elements in the embankment part of the mesh. 

           Step 6 In the Mesh menu, click on Element Properties... to display the element 
properties dialogue box. 

 
Figure  6-26:Element Properties for the Embankment 

           Step 7 Select the Linear Strain Triangle (non consolidating) option and the 
‘Sand’ material zone.  The Quadrilateral options are greyed out because you 
have selected three sided finite elements. 

           Step 8 Click on OK to exit, once you have finished. 
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           Step 9 Clear the selection, then select all of the quadrilateral elements in the 
embankment part of the mesh. 

           Step 10 Assign these elements to the ‘Sand’ material zone and give them a L. S. 
Quadrilateral (non consolidating) finite element type. 

           Step 11 Clear the selection, then select all of the new triangular elements that you created 
beneath the toe of the embankment. 

           Step 12 Assign these elements to the ‘Gault clay’ material zone and give them a Linear 
Strain Triangle (consolidating) finite element type. 

           Step 13 Clear the selection, then select the two quadrilateral elements beneath the toe of 
the embankment. 

           Step 14 Assign these elements to the ‘Gault clay’ material zone and give them a L. S. 
Quadrilateral (consolidating) finite element type. 

           Step 15 You should check that all element types and material zones have been correctly 
assigned.  When you are viewing material zones, the Graphics Window should 
look as shown below 

 

 

Figure  6-27:Fully Assigned Material Zones 
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           Step 16 In the View menu, click on Element Types.  The Graphics Window should look 
as shown below, provided that all of the elements have been created in identical 
fashion to those in this example. 

 
Figure  6-28:Fully Assigned Finite Element Types 

6.3.13 Defining Boundary Conditions 
Boundary conditions describe to the finite element analysis, the ways in which the mesh is physically 
restrained from moving.  This is achieved by applying fixities to edges and nodes in the mesh. 

Once defined, fixities apply in all successive increment blocks.  The Fixities dialogue box and the 
Graphics Window (if View Fixities is toggled on) will only display any fixity that is applied during the 
current increment block. 

Fixities are applied in the following stages: 

 In situ fixities 

 Pore pressure fixities (the water table) 

 Construction sequence fixities 

Defining In Situ Fixities 
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In this example the left and right-hand edges are restrained horizontally, and the base is restrained both 
horizontally and vertically during in situ stage.  The following procedure defines fixities for the in situ 
stage: 

           Step 1 Select ‘In situ’ from the Increment Block list box on the main toolbar. 

           Step 2 In the Select menu, click on Edges. 

           Step 3 Select all the far-left-hand and far-right-hand (vertical) edges of the mesh by 
clicking on them. 

           Step 4 In the Increment menu, click on Fixities... to display the Edge Fixity dialogue 
box. 

 
Figure  6-29:Defining Edge Fixities 

           Step 5 Click on the X Displacement option. 

           Step 6 Specify ‘0’ X direction fixities in the Start Node and Finish Node text 
boxes.  Set the Mid Value to zero either by entering it directly, or by clicking 
on the Interpolate button. 

           Step 7 The Edge Fixity dialogue box should now look like Figure  6-29.  Click on OK 
to exit, once you have finished. 

           Step 8 In the Select menu, click on Clear Selection to ensure that no edges remain 
selected.  Select the bottom (horizontal) edges of the mesh by clicking on them. 

           Step 9 In the Increment menu, click on Fixities... and define zero X displacement 
fixities as before. 

           Step 10 Click on the Y Displacement option. 

           Step 11 Specify Y direction fixities of zero in the Start Node and Finish Node and 
Mid Value text boxes. 

           Step 12 Click on OK to exit, once you have finished. 
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           Step 13 The Graphics Window should now look as shown below. The size of the fixity 
icons can be changed in the Defaults dialogue box (accessed via the Options 
menu). 

 

Figure  6-30:Fully Defined In Situ Fixities 

Defining The Water Table 
A water table is added in the first increment block by setting the total pore water pressure along material 
zone boundaries.  The following procedure defines pore water pressure fixities: 

           Step 1 Select “Define water table” from the Increment Block list box on the main 
toolbar. 

           Step 2 In the Select menu, click on Edges. 

           Step 3 Select all horizontal edges along the bottom of the mesh by clicking on them 
(you will not have to do this unless you  have cleared the selection). 

           Step 4 In the Increment menu, click on Fixities... to display the Edge Fixity dialogue 
box. 
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Figure  6-31:Setting Pore Water Pressures 

           Step 5 Click on the Pore Water Pressure option. 

           Step 6 Click on the Total option. 

           Step 7 Specify total pore water pressures of ‘168.72’ in the Start Node and Finish 
Node text boxes.  Set the Mid Value by clicking on the Interpolate button. 

           Step 8 The Edge Fixity dialogue box should now look like Figure  6-31.  Click on OK 
to exit, once you have finished. 

           Step 9 In the Select menu click on Clear Selection, then select all horizontal edges 
with a Y co-ordinate of 15.5 metres. 

           Step 10 In the Increment menu, click on Fixities... and define total pore water pressure 
fixities as before, but with a value of ‘8.82’. 

           Step 11 Click on OK to exit, once you have finished. 

           Step 12 In the Select menu click on Clear Selection, then select all of the top 
horizontal edges (i.e. with a Y co-ordinate of 16.4 metres). 

           Step 13 In the Increment menu, click on Fixities... and define zero total pore water 
pressure fixities. 

           Step 14 Click on OK to exit, once you have finished. 

           Step 15 The Graphics Window should now look as shown below  
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Figure  6-32:Fully Defined Pore Pressure Fixities  

Defining Construction Sequence Fixities 
The right-hand vertical edges of the embankment are fixed horizontally as the layers are constructed.  The 
following procedure defines fixities during construction: 

           Step 1 Select ‘Add layer 2’ from the Increment Block list box on the toolbar. 

           Step 2 In the Select menu, click on Clear Selection, then select the right-hand 
vertical edge of the layer just added to the embankment. 

           Step 3 In the Increment menu, click on Fixities... and define zero X displacement 
fixities.  This procedure is the same as already described in Defining In Situ 
Fixities. 

           Step 4 The Graphics Window should now look as shown below. 
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Figure  6-33:Defining Horizontal Fixities for the Second Layer 

           Step 5 In this way, define horizontal fixities for the right-hand vertical edge of each of 
layers 3, 4 and 5 as they are added. 

6.3.14 Running The Analysis 
The Project should now be saved.  Provided you have followed all of the steps described above, 
preparation of the Project using the Pre-Processor is complete and the analysis is ready to be run, as 
described below. 

           Step 1 In the File menu, click on Run Analysis... to display the Run Analysis 
dialogue box. 
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Figure  6-34:Run Analysis dialogue box 

           Step 2 Click on the Create CRISP Files Now button.  Provided you have followed 
all of the above steps correctly, this will create .GPR and .MPD files for your 
Project.  A message box will appear after each stage has been completed. 

           Step 3 Click on the Run Analysis button.  This will prompt you to save your Project 
and will then run the finite element analysis. 

           Step 4 You will be task switched into a DOS box where the analysis will commence.  
Equilibrium error messages are issued for each increment of the analysis.  

Warning If the error ever exceeds about 0.02% then this is an indication that 
something is wrong with the input data.  You should quit the analysis 
immediately (by pressing CTRL-BREAK) and double check all data in the 
Project in the Pre-Processor. 

 If there is a problem, first check the in situ stress conditions, then check 
the material properties.  Check also that fixities are correctly defined and 
that the Project Setup is correct. 

           Step 5 Once the analysis is complete, the output is converted into a Microsoft Access 
2.0 database.  Once this is complete, you will see the Analysis Docker dialogue 
box: 
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Figure  6-35:The Analysis Docking Module 

           Step 6 If the Project ran successfully (without errors- the message to the right of the 
Project name should say ‘OK’), click on the Post-Processor button to load 
the Project into the CRISP2D Post-Processor. 

6.4 Post-Processing 
In this section you will be introduced to the following features: 

 Displacement Plots 

 Instance Graphs 

 Duration Graphs 

 Stress State Code Plots 

6.4.1 Introduction 
If you entered the Post-Processor directly from running the analysis, the embankment Project will already 
be loaded.  However you may also enter the Post-Processor by double-clicking on its icon in the 
CRISP2D program group, in Windows’ Program Manager.  In this case, you should select Open 
Project... from the File menu and, provided the analysis has been successfully run, you will be able to 
post process the results from your analysis. 

6.4.2 Displacement Plots 
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Displacement plots are drawn directly onto the Graphics Windows.  They provide a representation of how 
the mesh has deformed at any stage in the analysis.  You can view either vector displacements or the 
deformed mesh at any specified magnification. 

The displacement plot described below, illustrates the final shape of the mesh at the end of the last 
increment of the analysis  By comparison with the experimental work, this point represents collapse of the 
centrifuge prototype embankment. 

           Step 1 Select Displacement Plots... from the Plots  menu.  This displays the 
Displacement Plot dialogue box. 

 
Figure  6-36:Setting Up A Displaced Mesh Plot 

           Step 2 Click on the New button to create your plot and change the title to “Final 
deformed mesh”. 

           Step 3 Select the Deformed Mesh option. 

           Step 4 Ensure that Absolute is selected and enter a Start increment of  101. 

           Step 5 Set a Magnification Factor of 1 (the default).  The Displacement Plot dialogue 
box should now look similar to Figure  6-36. 

           Step 6 Click on OK to exit, once you have finished.  Figure  6-37 shows the displaced 
mesh plot in Graphics Window (a zoom window has been executed to show 
more clearly the region beneath the embankment). 
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Figure  6-37:Deformed Mesh at Collapse 

6.4.3 Instance Graphs 
Instance Graphs allow you to investigate output for selected integration points or nodes at particular 
increments in the analysis. 

The graph described below compares the deformation occurring between the start of the analysis and the 
end of the third layer’s consolidation with deformations occurring between this point and the end of the 
fifth layer’s consolidation. 

           Step 1 In the Plots menu, click on Clear Current Plot.  This makes it easier to see 
which nodes you are selecting. 

           Step 2 In the Select menu, click on Nodes. 

           Step 3 Select all of the nodes whose Y co-ordinate is 15.5.  These points, just beneath 
the top of the clay layer, are the source from which the graph will be drawn. 

           Step 4 In the Plots menu, click on Instance Graphs... to display the Instance Graphs 
dialogue box. 
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Figure  6-38:Setting Up An Instance Graph 

           Step 5 Click on the New button to create a new graph whose data is taken from the 
selected nodes.  Change the title to “Comparison of Relative Vertical 
Displacements”. 

           Step 6 Click on Incremental and enter Start and Finish values of 1 and 61. 

           Step 7 Choose ‘X Co-ordinate’ as X Axis Data and ‘Vertical displacement’ as Y 
Axis Data. 

           Step 8 Click on the Add Data Set button and select Data Set 2 from the Data Set 
Number list. 

           Step 9 Click on Incremental and enter Start and Finish values of 61 and 101.  The 
Instance Graph Dialogue box should look like Figure  6-38. 

           Step 10 Click on OK to exit, once you have finished.  You should see a graph similar to 
that displayed in Figure  6-39. 

           Step 11 The appearance of the graph can be altered in the in the Graph Configuration 
dialogue box.  This is accessed via the Options menu, or by double-clicking on 
the graph itself.  The options used in Figure  6-39 were 7 X axis divisions with 
minima and maxima of 0 and 70 respectively, 10 Y axis divisions with minima 
and maxima of -1.0 and 0.  The legend, axis labels, graph title and grid lines can 
also be changed in this dialogue box. 
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Figure  6-39:Comparison Of Relative Vertical Displacements 

           Step 12 The resulting graph indicates that the vertical displacements prior to the fourth 
layer being applied amount approximately 80% of the total displacements. 

6.4.4 Duration Graphs 
Duration graphs allow you to investigate the variation of output from individual integration points or 
nodes over the course of a specified range of increments. 

Up to 10 data sets (each one representing a different integration point or node) can be viewed on the same 
graph.  For this example, two integration points beneath the footing will be used. 

           Step 1 To reactivate the Graphics Window, click on Cascade, Tile Vertically or on 
Tile Horizontally in the Window menu.  These options allow you to switch 
between the Graphics Window and any graphs that are on display. 

           Step 2 In the Select menu, click on Integration Points and then on Clear 
Selection.  Select an integration point at the centroid of one of the finite 
elements in the Kaolin clay layer beneath the middle of the embankment.  (This 
graph was drawn from centroid of the fifth triangle up, in the second column in 
from the right of the mesh). 

           Step 3 In the Plots menu, click on Duration Graphs... to display the Duration Graphs 
dialogue box. 
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Figure  6-40:Setting Up A Duration Graph 

           Step 4 Click on the New button to create a new Duration graph and change the title to 
“Stress Path Beneath Embankment”. 

           Step 5 Ensure that the Increment Range starts at 1 and finishes at 101. 

           Step 6 Check each of the Critical State Lines check boxes. 

           Step 7 Click on the top left Stress Path Graph button (i.e. the q - p' button).  The 
Duration Graph dialogue box should now look like Figure  6-40. 

           Step 8 Click on OK to exit, once you have finished.  The graph displayed should look 
similar to Figure  6-41. 

           Step 9 You can configure the way the graph looks (axis labels, titles and legend) by 
double-clicking on the graph window and changing the set-up in the Graph 
Configuration dialogue box.  The options used in this case are 9 X axis divisions 
with minima and maxima of -200 and 1600 respectively, 8 Y axis divisions with 
minima and maxima of  0 and 800.  The line styles, symbol styles and legend 
have all been modified. 
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Figure  6-41:Stress Path Plot for a Point Beneath the Embankment 

6.4.5 Status Plots 
The Status Plot option covers a variety of different kinds of plot that allow you to represent, by use of 
vectors and coloured blocks, the patterns of variation of particular quantities across the entire mesh.  This 
is useful when you want to look at the formation of failure mechanisms or, if you are assessing the 
validity of your analysis.  It is this latter application to which the status plot is being applied in this 
example. 

Here, a stress state code plot is being used to determine whether or not the stresses in the soil are 
plausible. 

           Step 1 To reactivate the Graphics Window, click on Cascade, Tile Vertically or on 
Tile Horizontally in the Window menu.  Click on the Graphics Window to 
activate it and maximise it by clicking on the Maximise arrow in the top right 
hand corner of the window. 

           Step 2 In the Plots menu, click on Status Plots... to display the Status Plot dialogue 
box. 

Worked Examples 159 



 Post-Processing 

 
Figure  6-42:Setting Up A Stress State Code Status Plot 

           Step 3 Click on the New button to create a new Status plot and change the title to 
“Increment 1”. 

           Step 4 Select ‘Stress state codes’ from the Available Plots list. 

           Step 5 Enter ‘1’ into the Increment Number text box. 

           Step 6 Magnification Factor has no effect on a stress state code plot, so this can be 
ignored. 

           Step 7 The Status Plot dialogue box should now look like Figure  6-42.  

           Step 8 Click on OK to exit. 

           Step 9 In the View menu, click on Legend.  The Graphics Window should now look 
similar to Figure  6-43.  If the colour scheme is not clear, you can change it by 
going back into the Status Plot dialogue box, selecting the plot from the Plot 
Name list and clicking on the Colour button.  This displays the Stress State 
Colours dialogue box which allows you to change the colour used to represent 
each stress state. 
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Figure  6-43:Stress State Code Plot for Increment 1 

           Step 10 By reference to the Cam clay yield locus described in section 4.5 of the 
Technical Reference Guide, this plot clearly shows the difference in strength 
between the two clay layers, with the top (Gault clay) layer being the stiffer of 
the two.  This plot is useful as it correctly predicts that before any loading 
occurs, the soil is elastic. 

           Step 11 Any anomalies at this stage are caused by numerical conditions- in Figure  6-43, 
a row of integration points undergoing strain hardening can be seen close to the 
bottom of the mesh.  If this is a cause for concern, it can be easily remedied by 
using a slightly finer mesh and re-running the analysis. 

           Step 12 In the Plots menu, click on Status Plots to again display the Status Plot 
dialogue box. 

           Step 13 Click on New to create a new Status plot and change the title to “Increment 21”. 

           Step 14 Select ‘Stress state codes’ from the Available Plots list. 

           Step 15 Enter ‘21’ into the Increment Number text box. 

           Step 16 Click on OK to exit. 

           Step 17 The Graphics Window should now look similar to Figure  6-44. 
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Figure  6-44:Stress State Code Plot for Increment 21 

           Step 18 This plot shows the softer Kaolin clay beneath the embankment undergoing 
significant strain hardening.  Away from the embankment, the soil remains 
elastic.  The Gault clay beneath the embankment is variously undergoing strain 
hardening and strain softening, suggesting that its behaviour is not being 
accurately captured.  Use of smaller elements in this region may be advisable. 
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6.5 Summary 
By the end of this example you will have made use of the following features: 

 The Structured Mesh Generator 

 Creating finite elements manually 

 Cam clay 

 Consolidation analysis 

 Construction sequences 

 Displacement plots 

 Instance graphs 

 Duration graphs 

 Status plots 

6.6 Things To Try Next 
 Create status plots for increments 41, 61, 71, 81, 91 and 101.  These plots 

suggest that the region of greatest activity is in the Kaolin clay beneath the 
embankment. 

 Return to the Pre-Processor and save the Project under a different name.  Try 
modifying the super mesh so that the elements beneath the toe of the embank-
ment are slightly larger and the elements directly beneath the embankment are 
significantly smaller.  Run the analysis again and see how the status plots 
change.  The ideal mesh should exhibit no anomalous behaviour. 
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7 TUNNEL EXAMPLE 
 

7.1 Introduction 
The following steps will be covered: 

 Adding and removing elements 

 Using layers 

7.2 The Problem 
 

 

 

 

 

 

 

 

A 6 meter diameter tunnel is to be constructed at a depth of 25 meter below ground level. A pressure load 
is to be applied representing a new building.  

 

7.3 Setting up the mesh 
           Step 1 Start CRISP2D and choose Structured Mesh from the project setup menu. Click 

on All other Element types as we do not need the high order CuST element here. 

 

           Step 2 Click on Super Node List and enter the following nodes in the list 
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           Step 3 Next, make sure that the Create Elements in the Mesh menu is ticked, and create 
the following four elements (leave an empty box in the middle as shown in the 
figure below): 

 

 
 

           Step 4 Click on Select>Super Edges and click on each outer edge of the super mesh. 
Enter 4 divisions and use the Equal option. 

           Step 5 Select the diagonal super edges (click nearer the middle box on each diagonal 
edge), then enter 4 for the number of divisions, use a Factor of 5 and click on the 
option End 1 is K times End 2. You should get the super egde grading as shown 
below: 
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           Step 6 Next, click on Mesh>Material Properties and enter the following material 
parameters for the soil 
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 Setting up the mesh 

 

           Step 7 Enter another material zone by clicking on New in the Material Properties 
dialogue box and enter the following material parameters for the lining: 

 

           Step 8 Click on Select>Super Elements in the Super mesh and select all the elements in 
the super mesh. 

 

           Step 9 Click on Mesh>Element Properties and fill in the properties for the super 
elements as shown below. Ensure that you use the material zone you have 
created for the soil 
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           Step 10 Click on Mesh>Generate Finite Element Mesh to create the mesh. This should 
like as shown below. 

 
 

 

           Step 11 The next step involves manually creating the elements for the tunnel and the 
tunnel lining. First we create tunnel nodes. Click on Mesh>Tunnel Nodes and fill 
in the following values 
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 Setting up the mesh 

 
 

           Step 12 Click on Mesh>Tunnel nodes again to create another set of tunnel nodes to 
represent the outer limit of the linning. Fill in the following 

 

 
 

           Step 13 Create an extra node for the centre of the tunnel by clicking on Mesh>Node List 
and enter node coordinates of 25,25 for an extra node at the end of the list. 

 

           Step 14 Next, click on Mesh>Create Elements and create elements to fill in the empty 
box where the tunnel is to be dug out as shown below. Remember that we need 
to create all the elements before the tunnel is dug out. 
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 Setting up the mesh 

 

           Step 15 Click on Select>Domain Elements and select triangular elements you have just 
created manually, then select Mesh>Element Properties and assign these 
elements the following properties 

 
 

 
 

           Step 16 Do the same step above for the rectangular elements representing the lining and 
assign them the soil material zone but using LSQ (Quadrilateral elements). 
Remember that at the in-situ stage the lining does not exists and that these 
elements represent the soil. 

 

           Step 17 Click on Increment>In-situ stresses and enter the following stresses which 
corresponds to an elastic material with Ko=1 and a unit weight of 20KN/m3 
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 Setting up the mesh 

 

           Step 18 Next click on the edges of the mesh and apply fixties as shown in the figure 
below 

 

 
 

By now the in-situ mesh should be completed. We now need to introduce the elements representing the 
lining. 

 

           Step 19 Select the rectangular elements representing the lining and click on Mesh>Super 
Impose Elements and fill in the detail below.  

 

 
 

This will create a new set of elements on top of the selected elements but having the lining properties. 
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 Setting up the mesh 

You should now remove these new elements from the in-situ stage. They will be introduced when 
the lining is intalled.  

           Step 20 To remove these elements, click on Select>Domain Elements and select these 
lining elements (not the soil elements), then click on Increment>Remove 
Elements. 

 

           Step 21 Next, click on Increment>Define Increment Block Parameters and enter the 
following three load blocks 

 

 
 
 

           Step 22 Click OK and in the pre-processor click on the Excavate load block on the 
combo box of the current increment. 

           Step 23 Click on Select>Domain Elements and click on all the tunnel elements including 
the rectangular ones around the tunnel. Click on Increment>Remove Elements. 
This will complete the excavation stage. 

 

We now want to add the elements representing the lining.  

 

           Step 24 Select the Install Lining load block from the compo box of the Current 
Increment. The lining (concrete) elements cannot be seen as they are invisible at 
prersent. Click on View>Removed Elements and select the elements 
representing the lining (not the removed soil elements). Once you have 
completed the selection, click on Increment>Add Elements. Click on 
View>Present Elements to go back to the active (present) mesh. You should be 
able to see the lining elements present. 

 

           Step 25 Finally, select the last load block of Apply Pressure. Click on Select>Edges and 
select the edge shown below 
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 Setting up the mesh 

 

 

 
 

           Step 26 Click on Increment>Loads and enter the following values: 
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8 RETAINING WALL 
EXAMPLE  

8.1 Introduction 
This example lecture is designed to introduce you to the excavation sequences and layer control in 
CRISP2D.  

The following steps will be covered: 

 Adding and removing elements 

 Using layers 

 Animation Sequences 

 Anamation plots 

8.2 The Problem 
The dimensions and loading conditions of the problem are shown below. 

30 m

10 m
12 m

0.6 m

2.4 m

6.25 m

10 kPa

 
 

Figure 1:Problem dimensions 



 Generating a Mesh with the Structured Mesh Generator 

8.3 Generating a Mesh with the Structured Mesh 
Generator 

           Step 1 Start the CRISP2D pre-processor 

           Step 2 Click on File-New Project and select Structured Super Mesh 

           Step 3 In the project setup select  All Other Elements in the Element Type option, then 
click OK 

           Step 4 Click on Mesh-Super Node List and enter the following node numbers and 
coordiantes 

 
Node X-Coord Y-Coord 
1 0 0 
2 30 0 
3 30 12 
4 10 12 
5 10 5.75 
6 10 11.4 
7 0 12 
8 0 9.6 
9 10 9.6 
10 0 9 
11 10 9 
12 10 0 
13 0 

0 
15 30 5.75 
16 30 9 

30 
18 11.4 
19 30 11.4 
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 Generating a Mesh with the Structured Mesh Generator 

 
 

           Step 6 Once you have completed creating the super mesh, click on Super Node 
Numbers  

           Step 7 Click on Select Super Edges and click on the top edge between nodes 7 and 4 as 
shown above. Make sure you click nearer to node 4 than to node 7 so the pink 
square marker is on node 4 

           Step 8 Click on Mesh-Super Edge Grading and enter 4 for No. Divisions and 3 for 
Factor(k) and click on the option End 1 is k times End 2 as shown below 
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 Generating a Mesh with the Structured Mesh Generator 

These divisions will be the same for all edges parallel to the edge you selected. 

 

           Step 9 Next clear the selected edge by clicking Select-Clear Selection, or use the short 
cut CTRL+L to clear the selection. 

           Step 10 Select the edge between nodes 4 and 3 and make sure you click nearer to node 4. 
Enter 5 for No. Divisions and 3 for Factor(k) and click on the option End 1 is k 
times End 2 as shown below. 

 
 

           Step 11 Clear the currently selected edge (Select-Clear Selection) 

           Step 12 Select the edge between nodes 7 and 18 and enter two 1 division and click on 
Equal Spacing 

Remember you have to enter edge divisions even if you have only one division on the side of the 
super element. 
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 Generating a Mesh with the Structured Mesh Generator 

 

           Step 13 Next, clear the currently selected edge, and click on the edge between nodes 8 
and 18. 

           Step 14 Enter 2 for No. Divisions and click on the option Equal Spacing. 

           Step 15 Clear the current edge selection and click on the edge between the nodes 14 and 
1. Click nearer to the node 14 so that the pink marker is on node 14. Enter 3 for 
No. Divisions and 3 for Factor(k) and click on the option End 1 is k times End 2 
as shown below 

 
All edges should by now have been sub-divided correctly. 
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 Defining Material Zones 
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           Step 1 Click on Mesh-Material Properties and enter the first material zone as shown 
below 

 
 

           Step 2 Click on New in the Material Properties dialogue box and enter details for the 
Concrete Slab as shown below 

 
 

           Step 3 Click on New in the Material Properties dialogue box and enter details for the 
sheet pile wall. This will make use of the Beam model in CRISP, which solves 
bending moments directly 



 Defining Material Zones 

 
 

           Step 4 Click on New in the Material Properties dialogue box and enter details for the 
horizontal prop. This also makes use of this will make use of the bar element 
which allows for transfer of axial forces 
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 Defining Material Zones 

           Step 5 Click on New in the Material Properties dialogue box and enter details for the 
bedrock as shown. 

 

8.4.1 Assigning Element Properties 
We have so far defined material zones but we have not associated these material zones with elements. We 
also need to specify the type of finite element to be generated (quadrilaterals or triangles, consolidation or 
non-consolidation).  

           Step 1 Click on Select-Domain Super Elements and click on all the elements in the 
super mesh. 

           Step 2 Click on Mesh-Element Properties and choose LSQ non-consolidation. For the 
material Zone, select Marine Clay (MCC). For the time being we will give the 
same properties for all the elements but would change that later 

8.4.2 Generating the Finite Element Mesh 
In the mesh menu click on Generate Finite Element Mesh. Your mesh should like as shown below. You 
can view the element numbers by clicking on View-Element Numbers. 

Worked Examples 181 



 Defining Material Zones 

 

8.4.3 Defining the elements for the concrete slab 
We now need to define the elements which form the concrete slab which is to be added after the 
excavation. There are two way of doing this: 

Method 1 
Create new elements on top of elements 6, 15 and 22 (see above mesh). You do that as follows 

           Step 1 click on Mesh-Create Elements and click on the four corner nodes of each of the 
elements 6,15 and 22. This will create a new element on top of the existing soil 
element 

           Step 2 Then select these new elements, assign element properties for them using Mesh-
Element Properties. Then select these newly added elements and remove them 
from the in-situ stage using Increment-Remove Elements 

Method 2 
You can create a new layer of elements using Layers.  
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 Defining Material Zones 

           Step 1 First click on View-Layers and click on Add. Enter a layer name. Lets say 
Concrete Slab. 

           Step 2 Next click on Mesh-Super Impose Elements and fill in details as below. The 
super-imposed layer description should be the new layer (Concrete Slab). Its 
associated material zone should be the Concrete Slab which you have defined 
earlier on. We will use non-consolidation elements for the concrete slab. 

 
 

           Step 3 Click OK and you will see a new set of elements created on top of the existing 
soil elements. 

           Step 4 Now we need to remove these elements from the in-situ stage. You can either 
click on these elements and select the concrete slab elements from the multi-
selection menu, or you can switch off the original soil layer so that you can 
select the concrete elements more easily. To do that you click on View-Layers 
and untick the original layer. Then select the concrete elements and click on 
Increment Remove Elements. 

           Step 5 Then click on View-layers and tick on original layer so as to be able to see it 
again. 
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 Defining Material Zones 

8.4.4 Defining the elements for the wall and prop 
           Step 1 Click on Mesh- Create elements and start creating the wall elements. We will 

use beam elements for this which will produce the bending moments for us.  

           Step 2 To create the element between nodes 29 and 34, you click on 29, then 34 then 29 
again, then you commit the element. Proceed in the same way to create the wall 
elements between nodes 34-4 , 4-9, 9-74, 74-79, and 79-82 

           Step 3 Once you have completed creating the wall elements, you would need assign 
element properties for them and then remove them from the in-situ stage.  

           Step 4 To assign element properties click on Select-Line Elements and click on the 
wall elements, then click on Mesh-Element Properties and chose the material 
zone Sheet Pile Wall (Beam).  

           Step 5 Next select these line elements and click on Increment-Remove Elements so 
that they are not present in the in-situ stage. 

           Step 6 Do the same procedure for the prop which is between nodes 79 and 78 

 

 

8.4.5 Assigning Element Properties for other 
material zones 

Select on the bottom row of the quadrilateral elements and click on Mesh-Element properties. Make sure 
that these elements have the material zone Bedrock (Elastic) 

8.4.6 Defining Boundary Conditions 
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 Defining Material Zones 

           Step 1 Click on Select-Edges, then select all the vertical edges on the left and right sides 
of the mesh. 

           Step 2 Click on Increment-Fixities and make sure that the edges have zero fixity in the 
x-direction. 

           Step 3 Clear the selection and select the bottom edges. Click on Increment-Fixities and 
make sure that these edges have zero fixities in both x and y directions. 

8.4.7 Defining insitu stresses 
Click on Increment-Define In situ stress conditions and enter the following: 

 

8.4.8 Installing the wall 

           Step 4 Select the "Install Sheet Pile Wall" increment from the increment drop down list. 

           Step 5 Ensure that you are currently viewing the removed elements and select the 1D 
elements that represent the wall. 

           Step 6 Select "Add elements" from the increment menu. 

           Step 7 The elements will now disappear from this view and will be added to the 
analysis during the  first increment block 

8.4.9 Apply overburden pressure load 
           Step 1 Create another increment block by clicking on Increment-Define Increment 

Blocks and enter a new increment block named Initial Excavation 

           Step 2 Select the edges between nodes 81-100-99-98, then select Increment-Load and 
apply a normal load of 10 Kpa. 
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 Defining Material Zones 

Create another increment block and call it Excavate Stage 1 

           Step 1 Select the "Excavate Stage 1" block from the increment drop down list. 

           Step 2 Select the two top rows of elements to the left of the wall 

           Step 3 Select "remove elements" from the "increment" menu. 

           Step 4 The excavation stage is now complete and the screen should look like figure 5 

 

8.4.11 Installing the crest prop 
Create another increment block and call it Install prop 

           Step 1 Select the "Install prop" increment from the increment drop down list. 

           Step 2 View the removed elements by selecting "removed elements" from the "view" 
menu 

           Step 3 Select the 1D element that represents the Strut. 

           Step 4 Select "add elements" from the "increment" menu.   

           Step 5 Introduce a nodal fixity to the free end of the prop so that it is held in both x and 
y directions. You do that by clicking on Select-Nodes, then select the node on 
the free end of the prop. Select Increment Fixities and introduce zero fixities in 
the x and y directions. 
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 Defining Material Zones 

           Step 6 View present elements by selecting "present elements" from the "view" menu.  
The analysis should now look like figure 6. 

Figure 6 - Strut installed 

8.4.12 Continue excavation 
Create another increment block and call it "Excavate final stage" 

           Step 1 Select the "Excavate final stage" increment from the increment drop down list. 

           Step 2 Select the top three rows of elements to the left of the wall 

           Step 3 Select "remove elements" from the "increment" menu. 

           Step 4 The excavation stage is now complete and the screen should look like figure 7 
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 Defining Material Zones 

 
Figure 7 - excavation complete 

8.4.13 Installing base slab 
The final stage of constuction is to install the base slab. Create another increment block and call it 
"Placement of Concrete" 

           Step 1 Select the "Placement of concrete" increment from the increment drop down list. 

           Step 2 View the removed elements by selecting "removed elements" from the "view" 
menu. 

           Step 3 Select the slab elements.  (You will find it easier to select the slab element if you 
turn the original layer off) 

           Step 4 Select "add elements" from the "increment" menu. 

           Step 5 Your excavation stages are now complete and you are ready to run the analysis. 
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 Post Processing 

Figure 8 - Completed analysis. 

8.4.14 Running The Analysis 
You should save the Project now.  This concludes the pre processing for this particular problem so all that 
remains is for you to run the finite element analysis program. 

           Step 6 Select Save from the File Menu. 

           Step 7 In the File menu, click on Run Analysis... to run the finite element analysis.  
This displays the Run Analysis dialogue box. 

           Step 8 Click on Create CRISP Files Now.  This will write two files with the 
extensions .GPD and .MPD to disk.  These files contain the input data required 
by the finite element analysis program. 

           Step 9 Click on Run Analysis Now.  This will task switch you to a DOS box and 
will run the finite element program using the data files just created. 

           Step 10 When the analysis is finished, you will be returned to Windows and the output 
from the analysis is converted into a Microsoft Access database.  A percentage 
bar informs you as to how long you have left to wait. 

8.5 Post Processing 
In this section you will be introduced to the following features: 

 Bending moment plots 

 Stress state plots 
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 Post Processing 

 Animation sequences 

8.5.1 Bending Moment plots 
           Step 1 Click on View-Material zones 

           Step 2 Go to the last Increment block (Placement of Concrete) 

           Step 3 Click on Select -Line Elements and select the element representing the wall. 

           Step 4 Click on Plots-Bending Moment Plot 

           Step 5 Fill in the Bending Moment plot as shown below. Remember to choose the last 
increment in the Start box so the that bending moment for the last increment 
could be presented 

 
 

           Step 6 Try doing a similar plot for the 2D quadrilateral elements which represent the 
concrete slab. 

8.5.2 Stress State plot 
           Step 1 Clear the previous bending moment plot by clicking on Plots-Clear Current plot 

           Step 2 Click on Plots-Status plot and fill in the dialogue box as shown below. 
Remember to choose the last increment in the Increment Number box 

Worked Examples 190 



 Post Processing 

           Step 3 Click on View-Legend to see what the stress codes mean 

8.5.3 Animation plots 
 

8.5.4 Setting up an animation sequence. 
 
Before you can run an animation you must define a sequence of increments to display in the animation.   

           Step 2 Click on the "new" button to define a new sequence.  This will display all the 
increments that have output defined in the left hand list. 

           Step 3 Select all the increments by selecting the first and then holding down the shift 
key while selecting the last. 

           Step 4 Click the ">>" button to add the selected increments to the list on the  right hand 
side.  See figure 10 
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 Post Processing 

 

Figure 10 - Setting up an anlaysis sequence 

8.5.5 Running an animation 
           Step 1 Select deformed mesh plots from the animation menu 

           Step 2 Click the new button to define a new plot 

           Step 3 Select "New animation sequence 1" from the Animation drop down list 

           Step 5 Set the scale factor = 1.  The animation plot form should not appear as figure 11 

           Step 6 Click OK to display the animation plot. 
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Figure 11 - deformation plot animation form. 

8.5.6 Benefits of Animation plots. 
In previous examples we have seen how you can plot the deformed mesh at any increment block.  If you 
have a large analysis it can be a time consuming process to view a deformed mesh for each stage.  The 
animation plots allow you to view all stages of the analysis at once and locate areas of problems in you 
analysis faster. 

8.5.7 Things to try next 
With the experience you have gained from this and previous analysis try the follow; 

 
• Run an animation plot for stress state codes (you can use the sequence set up for the deformation 

plot) 
• Plot a graph showing the deformation of the wall at the end of each construction stage. 
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